diff mbox series

[bug#57872] Furthermore, get sources from Github

Message ID CAFHYt56DQezf9=VO=5nZb7kjMez8VWGjS2H+aqGodOLwJ5J-NA@mail.gmail.com
State Accepted
Headers show
Series [bug#57872] Furthermore, get sources from Github | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Lechner Sept. 18, 2022, 4:36 p.m. UTC
Let's use this combined commit instead.

Getting the source from Github avoids a pointer from 'guix lint' about
the sources not being archived on Software Heritage, and there is an
automatic updater.

Thanks!
diff mbox series

Patch

From 1055d3ffac5b26645cedde3984d86e5c50cc3c84 Mon Sep 17 00:00:00 2001
From: Felix Lechner <felix.lechner@lease-up.com>
Date: Fri, 16 Sep 2022 10:36:36 -0700
Subject: [PATCH] gnu: xkeyboard-config: Update to 2.36.

* gnu/packages/xorg.scm (xkeyboard-config): Update to 2.36.
[source]: Switch to Github repo, which is archived on Software
Heritage, plus there is an automatic updater.
[build-system]: Use meson-build-system.
[inputs]: Indent for common style.
[native-inputs]: Drop labels.
---
 gnu/packages/xorg.scm | 32 +++++++++++++-------------------
 1 file changed, 13 insertions(+), 19 deletions(-)

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 4cde48aa1b..3e021483b9 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3880,25 +3880,19 @@  (define-public xkbutils
 (define-public xkeyboard-config
   (package
     (name "xkeyboard-config")
-    (version "2.34")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (string-append
-              "ftp://ftp.freedesktop.org/pub/xorg//individual/data/xkeyboard-config/xkeyboard-config-"
-              version
-              ".tar.bz2"))
-        (sha256
-          (base32
-            "1kmq2ykwmh10sd6155gml4jhdxmvsll6xdg7zw86czpfhrvd48dk"))))
-    (build-system gnu-build-system)
-    (inputs
-      (list libx11 xkbcomp-intermediate))
-    (native-inputs
-      `(("gettext" ,gettext-minimal)
-        ("perl" ,perl)
-        ("pkg-config" ,pkg-config)
-        ("python" ,python)))
+    (version "2.36")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/freedesktop/xkeyboard-config")
+                    (commit (string-append name "-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0qmfcvcg1jmzfk6xpcdg14gwy83hqw0k16z96p7f5np11xn2jyvy"))))
+    (build-system meson-build-system)
+    (inputs (list libx11 xkbcomp-intermediate))
+    (native-inputs (list gettext-minimal perl pkg-config python))
     (home-page "https://www.x.org/wiki/")
     (synopsis "Xorg XKB configuration files")
     (description

base-commit: ce3b51a4c6bef22e35ca04a945917510627fc3a7
-- 
2.37.3