diff mbox series

[bug#55762] Upgrade linux-pam to 1.5.2

Message ID CAFHYt54vnWZRi59GkkUuqebNdS6NYs9gu=0q6EsFUvMXWP1-bQ@mail.gmail.com
State Accepted
Headers show
Series [bug#55762] Upgrade linux-pam to 1.5.2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Felix Lechner June 2, 2022, 12:09 p.m. UTC
Control: tags -1 + patch

Hi,

For my work in making PAM configurable in Guile, I rely on the foreign
function interface (FFI). The automatic generation of that interface
requires Pkgconfig files. Those files are not available in Guix.
Linux-PAM started shipping them in the release after the one we have.
The attached patch upgrades linux-pam to version 1.5.2.

The changes are further documented in the commit message.

I am new to Guix and already use the new version of linux-pam locally
(via Guix System) but I was unable to test the patch according to the
requirements and recommendations listed for this submission. [1]

This email was sent to -devel in lieu of -mentors, which does not
exist. Any guidance is much appreciated. Thanks for taking a look!

KInd regards
Felix Lechner

[1] https://guix.gnu.org/en/manual/devel/en/html_node/Submitting-Patches.html

Comments

Tobias Geerinckx-Rice June 2, 2022, 6:16 p.m. UTC | #1
Felix,

Felix Lechner 写道:
> For my work in making PAM configurable in Guile, I rely on the 
> foreign
> function interface (FFI). The automatic generation of that 
> interface
> requires Pkgconfig files. Those files are not available in Guix.
> Linux-PAM started shipping them in the release after the one we 
> have.
> The attached patch upgrades linux-pam to version 1.5.2.

Thanks for working on both!

> The changes are further documented in the commit message.

And thanks for writing a clear commit message.  A few thoughts:

- The ‘gnu: foo: Update to x.y.z’ messages you see in the Guix 
  commit history are standardised.  The format's documented in the 
  GNU ‘(standards)Change Logs’ info page, but just take a stroll 
  through the history to get a feel for the majority of cases.

- Don't feel obligated to explain why you're upgrading a package, 
  although you're free to do so if you like (it was interesting 
  and I learnt something).

  Assuming no regressions, we always prefer to ship newer versions 
  of things.

- And finally, a personal windmill of mine:

> The extra argument to ./configure is needed to sidestep an issue
> upstream.[1]

  belongs in the code, where your fellow hackers can see it, not 
  buried in the commit log where $nobody will:

  ;; Work around 
  <https://github.com/linux-pam/linux-pam/issues/466>.

As you might now, this update rebuilds a good part of the world 
and will have to pass through the core-updates branch…

  $ guix refresh -l linux-pam | cut -d: -f1

> I am new to Guix and already use the new version of linux-pam 
> locally
> (via Guix System) but I was unable to test the patch according 
> to the
> requirements and recommendations listed for this submission. [1]

…so it's impressive if you rebuilt most of your entire system 
based on the new nyacc/linux-pam packages.

What still needs to be done, and which problems did you encounter?

Kind regards,

T G-R
diff mbox series

Patch

From 592d8156014090fefe8b9b1da8cada6aa2fa120a Mon Sep 17 00:00:00 2001
From: Felix Lechner <felix.lechner@lease-up.com>
Date: Tue, 31 May 2022 11:40:04 -0700
Subject: [PATCH] Update linux-pam to 1.5.2.

This version ships three Pkgconfig files for Linux-PAM that make it
possible to generate automatic FFI bindings via 'nyacc compile-ffi'.

The current PAM version in Guix offers no Pkgconfig files at all.
Upstream started shipping them in version 1.5.2.

The extra argument to ./configure is needed to sidestep an issue
upstream. [1]

[1] https://github.com/linux-pam/linux-pam/issues/466
---
 gnu/packages/linux.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2af32fc88f..8a08a56bb4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1579,7 +1579,7 @@  (define-public xpadneo
 (define-public linux-pam
   (package
     (name "linux-pam")
-    (version "1.5.1")
+    (version "1.5.2")
     (source
      (origin
        (method url-fetch)
@@ -1588,7 +1588,7 @@  (define-public linux-pam
              version "/Linux-PAM-" version ".tar.xz"))
        (sha256
         (base32
-         "1z4jayf69qyyxln1gl6ch4qxfd66ib1g42garnrv2d8i1drl0790"))
+         "0kgrsj2scv5mx6w925h9hxf11jnqqs9z8s22aw94b90xm4qp3v74"))
        (patches (search-patches "linux-pam-no-setfsuid.patch"))))
 
     (build-system gnu-build-system)
@@ -1604,6 +1604,9 @@  (define-public linux-pam
        #:configure-flags (list (string-append "--includedir="
                                               (assoc-ref %outputs "out")
                                               "/include/security")
+                               (string-append "--libdir="
+                                              (assoc-ref %outputs "out")
+                                              "/lib")
 
                                ;; XXX: <rpc/rpc.h> is missing from glibc when
                                ;; cross-compiling, so we have to disable NIS

base-commit: 20432b839b6bc9e30c156d412597b734a726940d
-- 
2.36.1