diff mbox series

[bug#58658] go-golang-org-x-net: Update to 0.1.0.

Message ID CAFHYt54A9Bh5-cYz8ywhsdk2h0NMxC-=CnEMmwjLh7vbU_e0hA@mail.gmail.com
State New
Headers show
Series [bug#58658] go-golang-org-x-net: Update to 0.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Lechner Oct. 20, 2022, 12:47 p.m. UTC
Control: tags -1 + patch

Hi,

Our version was dated and too old for the upcoming packaging of
Gocryptfs in Guix.

Rebuilds 23 packages. Thanks!

Kind regards
Felix Lechner

Comments

Christopher Baines Nov. 20, 2022, 11:22 a.m. UTC | #1
Felix Lechner via Guix-patches via <guix-patches@gnu.org> writes:

> Control: tags -1 + patch
>
> Hi,
>
> Our version was dated and too old for the upcoming packaging of
> Gocryptfs in Guix.
>
> Rebuilds 23 packages. Thanks!

Looking at https://qa.guix.gnu.org/issue/58658 I think this change
breaks the go-golang-zx2c4-com-wireguard and go-ipfs packages. Do you
see those fail to build locally?

Thanks,

Chris
Felix Lechner Nov. 20, 2022, 1:20 p.m. UTC | #2
Hi Chris,

On Sun, Nov 20, 2022 at 3:23 AM Christopher Baines <mail@cbaines.net> wrote:
>
> this change
> breaks the go-golang-zx2c4-com-wireguard and go-ipfs packages. Do you
> see those fail to build locally?

Yes, I see both of them failing.

I experimented with various newer versions of
go-golang-zx2c4-com-wireguard but could not get them to build. One
ominous error I saw was:

src/golang.org/x/net/internal/socket/sys_unix.go:35:38: undefined:
unix.RecvmsgBuffers
src/golang.org/x/net/internal/socket/sys_unix.go:47:9: undefined:
unix.SendmsgBuffers

Is it possible that the golang-1.17 used in our Golang build system is
too old? [1][2]

Thanks for looking!

Kind regards
Felix

[1] https://github.com/golang/go/issues/51382
[2] https://github.com/golang/go/issues/52512
Felix Lechner Dec. 19, 2022, 7:40 p.m. UTC | #3
Hi Chris,

The issue with go-ipfs and go-golang-zx2c4-com-wireguard was fixed
with the update of go-golang-org-x-sys that now preceeds the original
patch in this series.

As a bonus, I also updated go-golang-zx2c4-com-wireguard herein but
acceptance is not necessary. Please feel free to ignore that
particular patch.

Otherwise, the acceptance of this patch series will allow Gocryptfs to
become part of Guix. [1] Thanks!

Kind regards
Felix Lechner

[1] https://issues.guix.gnu.org/58768
Felix Lechner Dec. 21, 2022, 10:41 p.m. UTC | #4
Hi,

The newly proposed changes trigger the rebuilding of 919 packages. I
already retitled the bug. This patch now belongs into 'staging'.

Kind regards
Felix Lechner
Felix Lechner Jan. 5, 2023, 2:40 p.m. UTC | #5
Hi,

This updates the Golang modules to their latest available versions,
and rebases the patch series onto staging.

Kind regards
Felix Lechner
Felix Lechner March 5, 2023, 9:01 p.m. UTC | #6
Hi,

These bugs were superseded by a new bug that tracks the feature branch
for adding Gocryptfs. It can be found here. [1]

Closing.

Kind regards
Felix Lechner

[1] https://issues.guix.gnu.org/61989
diff mbox series

Patch

From c612245236aa7d2eb6c9b7d44701b394ead7f4ca Mon Sep 17 00:00:00 2001
From: Felix Lechner <felix.lechner@lease-up.com>
Date: Thu, 20 Oct 2022 05:40:37 -0700
Subject: [PATCH] gnu: go-golang-org-x-net: Update to 0.1.0.

* gnu/packages/golang.scm (go-golang-org-x-net): Update to 0.1.0.
(go-golang-org-x-net): Switch to gexp.
---
 gnu/packages/golang.scm | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ecef5e275e..c0f539ead0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2751,11 +2751,11 @@  (define-public go-golang-org-x-crypto
       (license license:bsd-3))))
 
 (define-public go-golang-org-x-net
-  (let ((commit "ba9fcec4b297b415637633c5a6e8fa592e4a16c3")
-        (revision "4"))
+  (let ((commit "1568cf9b43eddada579c44f99d04fe42a1f58dac")
+        (revision "0"))
     (package
       (name "go-golang-org-x-net")
-      (version (git-version "0.0.0" revision commit))
+      (version (git-version "0.1.0" revision commit))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -2764,15 +2764,17 @@  (define-public go-golang-org-x-net
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1hbqvy6r0s5h0dpdqw8fynl3cq0acin3iyqki9xvl5r8h33yb9bx"))))
+                  "1wh3021id07rbjci8hm4nb2ljaaafmvi6x93lsca3cis30af3d2a"))))
       (build-system go-build-system)
       (arguments
-       `(#:import-path "golang.org/x/net"
-         ; Source-only package
-         #:tests? #f
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'build))))
+       (list
+        #:import-path "golang.org/x/net"
+        ;; Source-only package
+        #:tests? #f
+        #:phases
+        #~(modify-phases %standard-phases
+            ;; Source-only package
+            (delete 'build))))
       (synopsis "Go supplemental networking libraries")
       (description "This package provides supplemental Go networking libraries.")
       (home-page "https://go.googlesource.com/net")

base-commit: 16d4ded6302c0650978203d0df83614896c453e8
-- 
2.38.0