[bug#33471] gnu: elogind: Update to 239.2.

Message ID CAFBTj=h-fot9=1tEyt4UDpASdmLyP48WUpG=Dh-dwLCSNQtwGg@mail.gmail.com
State Accepted
Headers show
Series [bug#33471] gnu: elogind: Update to 239.2. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Stefan Stefanović Nov. 24, 2018, 4:34 a.m. UTC
> Can you split this into two patches: one that switches the current
> elogind package to use "git-fetch", and afterwards this update?

Here is the first patch, that switches to git-fetch method.

> Please also remove the let binding so that we can keep the original
> indentation.  Those bindings are usually only necessary for packages
> that don't have a proper versioning scheme, unlike elogind.

I will start working on the second patch, which will include the above
suggestions.

Stefan.

Patch

From 7b3dfe0ebf7fb1d47f965cde284c52c9734bc994 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Stefan=20Stefanovi=C4=87?= <stefanx2ovic@gmail.com>
Date: Sat, 24 Nov 2018 05:20:29 +0100
Subject: [PATCH] gnu: elogind: Use git-fetch.

* gnu/packages/freedesktop.scm (elogind)[source]: Use git-fetch.
---
 gnu/packages/freedesktop.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 431cbd0c3..afcd63b54 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -229,13 +229,14 @@  the freedesktop.org XDG Base Directory specification.")
     (name "elogind")
     (version "232.4")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/elogind/elogind/"
-                                  "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/elogind/elogind")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1qcxian48z2dj5gfmp7brrngdydqf2jm00f4rjr5sy1myh8fy931"))
+                "06qqs6yfcwg8aiinqqvy5374pys6sspmvsrqz93c724hqq38d93z"))
               (patches (search-patches "elogind-glibc-2.27.patch"))
               (modules '((guix build utils)))
               (snippet
-- 
2.19.2