diff mbox series

[bug#40092] gnu: ocaml-menhir: Update to 20200211

Message ID CAEwRq=rLKfAU-rspytLXuHW6JuqT+cB2XDrZdQ0SrxRXqfW_tg@mail.gmail.com
State Accepted
Headers show
Series [bug#40092] gnu: ocaml-menhir: Update to 20200211 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll March 16, 2020, 5:01 p.m. UTC
The attached patch depends on the
previously submitted for inclusion dune 2.4.0
update (which may not go into master)

The package is switched from ocaml-build-system to dune-build-system.

This one is untested though

Comments

Leo Famulari May 29, 2020, 12:38 a.m. UTC | #1
On Mon, Mar 16, 2020 at 06:01:15PM +0100, Vincent Legoll wrote:
> The attached patch depends on the
> previously submitted for inclusion dune 2.4.0
> update (which may not go into master)
> 
> The package is switched from ocaml-build-system to dune-build-system.
> 
> This one is untested though

It's been a while... is this patch still waiting for something else?
Vincent Legoll May 29, 2020, 8:25 a.m. UTC | #2
Hello,

On 29/05/2020 02:38, Leo Famulari wrote:
> On Mon, Mar 16, 2020 at 06:01:15PM +0100, Vincent Legoll wrote:
>> The attached patch depends on the
>> previously submitted for inclusion dune 2.4.0
>> update (which may not go into master)
>>
>> The package is switched from ocaml-build-system to dune-build-system.
>>
>> This one is untested though
> 
> It's been a while... is this patch still waiting for something else?

Yes, this depends on dune 2 (we still have 1.11.3) which is breaking
compatibility by removing support for jhbuild. See details in issue:
#40091.

I'm not into ocaml, (was just trying to update packages, to get
acquainted with guix packaging). I think I was too optimistic with
those.

I'll let the ones who know handle this.

I don't know if this means closing the issues or letting them open
though...
Leo Famulari May 29, 2020, 5:12 p.m. UTC | #3
On Fri, May 29, 2020 at 10:25:34AM +0200, Vincent Legoll wrote:
> Yes, this depends on dune 2 (we still have 1.11.3) which is breaking
> compatibility by removing support for jhbuild. See details in issue:
> #40091.

Alright, I've set this patch as "blocked by" #40091 in the bug tracker.
Simon Tournier Oct. 15, 2020, 5:06 p.m. UTC | #4
Dear,

On Fri, 29 May 2020 at 13:12, Leo Famulari <leo@famulari.name> wrote:
> On Fri, May 29, 2020 at 10:25:34AM +0200, Vincent Legoll wrote:
>> Yes, this depends on dune 2 (we still have 1.11.3) which is breaking
>> compatibility by removing support for jhbuild. See details in issue:
>> #40091.
>
> Alright, I've set this patch as "blocked by" #40091 in the bug tracker.

The recent commit 339177956a updates dune to 2.7.1, therefore somehow
unblock 40091.  Could you try to rebase your patch?


All the best,
simon

PS:
It could be nice to have this recent version of menhir in v1.2. :-)
Christopher Baines Dec. 8, 2020, 8:19 p.m. UTC | #5
zimoun <zimon.toutoune@gmail.com> writes:

> Dear,
>
> On Fri, 29 May 2020 at 13:12, Leo Famulari <leo@famulari.name> wrote:
>> On Fri, May 29, 2020 at 10:25:34AM +0200, Vincent Legoll wrote:
>>> Yes, this depends on dune 2 (we still have 1.11.3) which is breaking
>>> compatibility by removing support for jhbuild. See details in issue:
>>> #40091.
>>
>> Alright, I've set this patch as "blocked by" #40091 in the bug tracker.
>
> The recent commit 339177956a updates dune to 2.7.1, therefore somehow
> unblock 40091.  Could you try to rebase your patch?
>
>
> All the best,
> simon
>
> PS:
> It could be nice to have this recent version of menhir in v1.2. :-)

This patch looks good to me, so I've gone ahead and pushed to master as
20e5658c0471c76cc297cfd30ad49f0585310e27.

Thanks,

Chris
diff mbox series

Patch

From d5a34254f0fdcc53f1f4c2614e5f2393d12e6cc9 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Mon, 16 Mar 2020 16:32:25 +0100
Subject: [PATCH] gnu: ocaml-menhir: Update to 20200211.

* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20200211.
[build-system]: Switch from gnu to dune.
[arguments]: Remove phases and make-flags.
[native-inputs]: remove field.
---
 gnu/packages/ocaml.scm | 15 ++++-----------
 1 file changed, 4 insertions(+), 11 deletions(-)

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 047bcc2d7b..6414fc0316 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -706,7 +706,7 @@  Emacs.")
 (define-public ocaml-menhir
   (package
     (name "ocaml-menhir")
-    (version "20181113")
+    (version "20200211")
     (source
      (origin
        (method git-fetch)
@@ -715,19 +715,12 @@  Emacs.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
-    (build-system ocaml-build-system)
+        (base32 "019izf51kdc7pzkw68zg8a2alc8lxw1gwdp7in970mr90n16b5zj"))))
+    (build-system dune-build-system)
     (inputs
      `(("ocaml" ,ocaml)))
-    (native-inputs
-     `(("ocamlbuild" ,ocamlbuild)))
     (arguments
-     `(#:make-flags `("USE_OCAMLFIND=true"
-                      ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
-       #:tests? #f ; No check target
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+     `(#:tests? #f)) ; No check target
     (home-page "http://gallium.inria.fr/~fpottier/menhir/")
     (synopsis "Parser generator")
     (description "Menhir is a parser generator.  It turns high-level grammar
-- 
2.25.1