diff mbox series

[bug#40083] gnu: Add blktrace.

Message ID CAEwRq=r6iuWO-DQcSwBPmfkY4Mm_75DDF8Q0O0XNydR+GA+2Vg@mail.gmail.com
State Accepted
Headers show
Series [bug#40083] gnu: Add blktrace. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll March 15, 2020, 8:52 p.m. UTC
Lightly tested on qemu VM, seems working OK

Comments

Vincent Legoll March 15, 2020, 9 p.m. UTC | #1
The use of git instead of released tarball is to have the commit for
fixing CVE-2018-10689
Vincent Legoll March 15, 2020, 9:47 p.m. UTC | #2
Dunno what to do about the packaged .py scripts, Should I patch the
shebang ? ("#! /usr/bin/env python") after adding python to inputs ?

On Sun, Mar 15, 2020 at 10:00 PM Vincent Legoll
<vincent.legoll@gmail.com> wrote:
>
> The use of git instead of released tarball is to have the commit for
> fixing CVE-2018-10689
>
> --
> Vincent Legoll
Vincent Legoll March 20, 2020, 9:52 p.m. UTC | #3
If/when the following series is merged, we will be able to remove the
local patch...

https://www.spinics.net/lists/linux-btrace/msg01154.html
diff mbox series

Patch

From 016265a4594239a9fa3f98031b0d89397b89cfe3 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sun, 15 Mar 2020 21:25:54 +0100
Subject: [PATCH] gnu: Add blktrace.

* gnu/packages/linux.scm (blktrace): New variable.
---
 gnu/packages/linux.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fda7570d89..4d966a2cad 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4013,6 +4013,37 @@  system calls, important for the performance of databases and other advanced
 applications.")
     (license license:lgpl2.1+)))
 
+(define-public blktrace
+  (let ((commit "f4f8ef7cdea138cfaa2f3ca0ee31fa23d3bcf1cc")
+        (revision "0"))
+    (package
+      (name "blktrace")
+      (version (git-version "1.2.0" revision commit))
+      (home-page
+        "https://git.kernel.org/pub/scm/linux/kernel/git/axboe/blktrace.git")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (sha256
+                 (base32 "1ihdfimg7mfcgdm6l09xfqx5kdyv42x743dxp3z3w65q5vd7xy89"))
+                (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:make-flags
+         (list "CC=gcc" (string-append "prefix=" %output))
+         #:tests? #f ; no tests
+         #:phases
+         (modify-phases %standard-phases (delete 'configure)))) ; no configure script
+      (inputs
+       `(("libaio" ,libaio)))
+      (synopsis "Block layer IO tracing mechanism")
+      (description "Blktrace is a block layer IO tracing mechanism which provides
+detailed information about request queue operations to user space.  It extracts
+event traces from the kernel (via the relaying through the debug file system).")
+      (license license:gpl2))))
+
 (define-public sbc
   (package
     (name "sbc")
-- 
2.25.1