diff mbox series

[bug#40032] gnu: Add nvme-cli

Message ID CAEwRq=r4yWqyJ6GEK+Bj4UibDvXkqBpphVchw7UmeTe04r7+5g@mail.gmail.com
State Accepted
Headers show
Series [bug#40032] gnu: Add nvme-cli | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll March 12, 2020, 1:13 a.m. UTC
Lightly tested (list & list-subsys commands)
on real hardware.

Guix pack'ed the binary and copied out of the
VM to run (in debian)

Comments

Leo Famulari March 12, 2020, 6:15 p.m. UTC | #1
On Thu, Mar 12, 2020 at 02:13:06AM +0100, Vincent Legoll wrote:
> +       #:tests? #f))

Why are the tests skipped? Please, always add a code comment here for
reviewers.
Vincent Legoll March 13, 2020, 11:14 p.m. UTC | #2
I'll investigate further and amend the patch

On Thu, Mar 12, 2020 at 7:15 PM Leo Famulari <leo@famulari.name> wrote:
>
> On Thu, Mar 12, 2020 at 02:13:06AM +0100, Vincent Legoll wrote:
> > +       #:tests? #f))
>
> Why are the tests skipped? Please, always add a code comment here for
> reviewers.
Vincent Legoll March 15, 2020, 5:07 p.m. UTC | #3
It looks like the tests require the presence of /sys/devices...

Should I just add that explanation as comment ?

On Sat, Mar 14, 2020 at 12:14 AM Vincent Legoll
<vincent.legoll@gmail.com> wrote:
>
> I'll investigate further and amend the patch
>
> On Thu, Mar 12, 2020 at 7:15 PM Leo Famulari <leo@famulari.name> wrote:
> >
> > On Thu, Mar 12, 2020 at 02:13:06AM +0100, Vincent Legoll wrote:
> > > +       #:tests? #f))
> >
> > Why are the tests skipped? Please, always add a code comment here for
> > reviewers.
>
>
>
> --
> Vincent Legoll
Leo Famulari March 15, 2020, 5:22 p.m. UTC | #4
On Sun, Mar 15, 2020 at 06:07:44PM +0100, Vincent Legoll wrote:
> It looks like the tests require the presence of /sys/devices...
> 
> Should I just add that explanation as comment ?

Yeah, I would say that they require sysfs, which is not accessible from
the build environment.

One could check with "ls -l /sys" in a build phase, or check the docs:

https://guix.gnu.org/manual/en/html_node/Build-Environment-Setup.html

Can you send a revised patch?
diff mbox series

Patch

From 9c836b206d65c0e80706c0a3730e77f508b10f43 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Thu, 12 Mar 2020 01:51:12 +0100
Subject: [PATCH] gnu: Add nvme-cli

* gnu/packages/linux.scm (nvme-cli): New variable.
---
 gnu/packages/linux.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b6048a8cfb..d7b31103c8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3544,6 +3544,35 @@  IDE driver subsystem.  Many external USB drive enclosures with SCSI-ATA Command
 Translation (@dfn{SAT}) are also supported.")
     (license (license:non-copyleft "file://LICENSE.TXT"))))
 
+(define-public nvme-cli
+  (package
+    (name "nvme-cli")
+    (version "1.10.1")
+    (home-page "https://github.com/linux-nvme/nvme-cli")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32 "12wp2wxmsw2v8m9bhvwvdbhdgx1md8iilhbl19sfzz2araiwi2x8"))
+              (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list "CC=gcc")
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (replace 'install
+                    (lambda _
+                      (zero? (system* "make" "install-spec" "PREFIX="
+                                      (string-append "DESTDIR=" %output))))))
+       #:tests? #f))
+    (synopsis "NVM-Express user space tooling for Linux")
+    (description "Utility to provide standards compliant tooling for NVM-Express
+drives.  It was made specifically for Linux as it relies on the IOCTLs defined
+by the mainline kernel driver.")
+    (license license:gpl2+)))
+
 (define-public rfkill
   (package
     (name "rfkill")
-- 
2.25.1