diff mbox series

[bug#40105] gnu: Add wol.

Message ID CAEwRq=qY8Qgz97Y_ivHb6qrUPieD95Jw-AUqoFnwOMUQ56sVUw@mail.gmail.com
State Accepted
Headers show
Series [bug#40105] gnu: Add wol. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll March 17, 2020, 3:04 p.m. UTC
Hello,

I don't know if having multiple packages doing the same is OK or not.
Nor do I know if there are differences between this "wol" and the
already packaged "wakelan"...

I initially put it in networking whereas wakelen is in admin...

Anyways, I did the work, I tested it works by waking a suspended
odroidn2 SBC with it...

So here it is, tell me if it is redundant to the point of not being useful.

FTR, I packaged this because my initial guix search was with the words
wol and wakeonlan, which did not find anything relevant, whereas
searching with "wake" would have found it...

There are a few packages with WoL capability:

etherwake,
http://gsd.di.uminho.pt/jpo/software/wakeonlan/

you can do it with netcat, etc...

Comments

Maja Kądziołka March 19, 2020, 12:55 p.m. UTC | #1
On Tue, Mar 17, 2020 at 04:04:51PM +0100, Vincent Legoll wrote:
> I don't know if having multiple packages doing the same is OK or not.
> Nor do I know if there are differences between this "wol" and the
> already packaged "wakelan"...

I don't think having multiple packages for doing something is
necessarily bad.

> +    (description "Tool to send a @code{magic} packet to wake another host
> +on the network.  This must be enabled on the target host, usually in the
> +BIOS.")

If I may ask, what's the rationale behind putting "magic" in a @code tag
here?

Apart from that, LGTM.

Regards,
Jakub Kądziołka
Vincent Legoll March 19, 2020, 2:57 p.m. UTC | #2
hello,

On Thu, Mar 19, 2020 at 1:55 PM Jakub Kądziołka <kuba@kadziolka.net> wrote:
> On Tue, Mar 17, 2020 at 04:04:51PM +0100, Vincent Legoll wrote:
> > I don't know if having multiple packages doing the same is OK or not.
> > Nor do I know if there are differences between this "wol" and the
> > already packaged "wakelan"...
>
> I don't think having multiple packages for doing something is
> necessarily bad.

Yep, me too, but I think I'll refrain from doing the other WoL packages...

> > +    (description "Tool to send a @code{magic} packet to wake another host
> > +on the network.  This must be enabled on the target host, usually in the
> > +BIOS.")
>
> If I may ask, what's the rationale behind putting "magic" in a @code tag
> here?

I think I copied that desc from somewhere else (maybe nixos) and it had quoting
around, and then guix lint told me to use @code instead, I probably should just
have removed the quotes... Nothing more than that, you can remove them if
you want to commit, or if you want I can resubmit without...
Maja Kądziołka March 28, 2020, 11:09 p.m. UTC | #3
On Thu, Mar 19, 2020 at 03:57:42PM +0100, Vincent Legoll wrote:
> > > +    (description "Tool to send a @code{magic} packet to wake another host
> > > +on the network.  This must be enabled on the target host, usually in the
> > > +BIOS.")
> >
> > If I may ask, what's the rationale behind putting "magic" in a @code tag
> > here?
> 
> I think I copied that desc from somewhere else (maybe nixos) and it had quoting
> around, and then guix lint told me to use @code instead, I probably should just
> have removed the quotes... Nothing more than that, you can remove them if
> you want to commit, or if you want I can resubmit without...

Sorry for taking a while to respond on this, but I pushed your patch as
commit 62b9ad19e3a6638f8e077753454fdf08ba586146 with two changes:
Firstly, I removed the @code tag as you suggested. Secondly, I removed
the references to `name' in the URL, since, as the contributing
guidelines suggest, the URL likely won't be valid if the name gets
changed.

Cheers!
Vincent Legoll March 29, 2020, 8:26 a.m. UTC | #4
Hello Jakub,

On Sun, Mar 29, 2020 at 12:09 AM Jakub Kądziołka <kuba@kadziolka.net> wrote:
> Sorry for taking a while to respond on this, but I pushed your patch as
> commit 62b9ad19e3a6638f8e077753454fdf08ba586146 with two changes:
> Firstly, I removed the @code tag as you suggested. Secondly, I removed
> the references to `name' in the URL, since, as the contributing
> guidelines suggest, the URL likely won't be valid if the name gets
> changed.

OK, no problem with taking time, and thanks for the fixes, I'll try to remember
doing those myself for the next patches.

Tchuss
diff mbox series

Patch

From d31a1ec3deb2ae39b5700af4592399d8a6430932 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sat, 22 Feb 2020 19:27:07 +0100
Subject: [PATCH] gnu: Add wol.

* gnu/packages/networking.scm (wol): New public variable.
---
 gnu/packages/networking.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 48b2570d9d..a22edd634b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2866,6 +2866,25 @@  Such interfaces are useful for VPN software, virtualization, emulation,
 simulation, and a number of other applications.")
     (license license:gpl2)))
 
+(define-public wol
+  (package
+    (name "wol")
+    (version "0.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/wake-on-lan/" name "/"
+                           version "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "08i6l5lr14mh4n3qbmx6kyx7vjqvzdnh3j9yfvgjppqik2dnq270"))))
+    (build-system gnu-build-system)
+    (home-page "https://sourceforge.net/projects/wake-on-lan/")
+    (synopsis "Implements Wake On LAN functionality in a small program")
+    (description "Tool to send a @code{magic} packet to wake another host
+on the network.  This must be enabled on the target host, usually in the
+BIOS.")
+    (license license:gpl2)))
+
 (define-public vde2
   (package
     (name "vde2")
-- 
2.25.1