diff mbox series

[bug#39528,v4] Add tunctl

Message ID CAEwRq=qPv4OFtU0OBXRkw6Z81wpFuUUGg1+z1aedg6k3kcpQ-Q@mail.gmail.com
State Accepted
Headers show
Series [bug#39528,v4] Add tunctl | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll Feb. 9, 2020, 11:40 p.m. UTC
Hello Nicolas,

thanks for your input, this version incorporates your feedback,
with a s/is/are/ and a capitalized first word of description.

WDYT?

Comments

Nicolas Goaziou Feb. 10, 2020, 12:03 a.m. UTC | #1
Vincent Legoll <vincent.legoll@gmail.com> writes:

> thanks for your input, this version incorporates your feedback,
> with a s/is/are/ and a capitalized first word of description.
>
> WDYT?

Almost good! :)

I removed the (mkdir-p bin), not necessary with `install-file', changed
the commit message so it follows Guix conventions, and fixed the URI of
the package.

Applied. Thank you!
diff mbox series

Patch

From 6ca58829af9ef6b2e4c5c90203229280bd8f2678 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sun, 9 Feb 2020 16:34:23 +0100
Subject: [PATCH] gnu: networking: Add tunctl

* gnu/packages/networking.scm (tunctl): New variable.
---
 gnu/packages/networking.scm | 39 +++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index ed339524c0..654506ffb8 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
 ;;; Copyright © 2019 Daniel Schaefer <git@danielschaefer.me>
 ;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2824,6 +2825,44 @@  easy-to-understand binary values.")
     (home-page "http://jodies.de/ipcalc")
     (license license:gpl2+)))
 
+(define-public tunctl
+  (package
+    (name "tunctl")
+    (version "1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/tunctl/tunctl-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1zsgn7w6l2zh2q0j6qaw8wsx981qcr536qlz1lgb3b5zqr66qama"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'bootstrap)  ; there is no configure.ac file
+         (delete 'configure)  ; there is no configure script
+         (delete 'check)      ; there are no tests
+         (replace 'build
+           (lambda _
+             (setenv "CC" "gcc")
+             (invoke "make" "tunctl")))
+         ;; TODO: Requires docbook2x to generate man page from SGML
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin")))
+               (mkdir-p bin)
+               (install-file "tunctl" bin))
+             #t)))))
+    (home-page "http://tunctl.sourceforge.net")
+    (synopsis  "Utility to set up and maintain TUN/TAP network interfaces")
+    (description "Tunctl is used to set up and maintain persistent TUN/TAP network
+  interfaces, enabling user applications to simulate network traffic.
+  Such interfaces are useful for VPN software, virtualization, emulation,
+  simulation, and a number of other applications.")
+    (license license:gpl2)))
+
 (define-public vde2
   (package
     (name "vde2")
-- 
2.25.0