diff mbox series

[bug#39537,v2] Add perl Config::Grammar

Message ID CAEwRq=qPSiM=dKrgPePOyyNCZQnKqZmbUcTdAQdNJmTB8Kehew@mail.gmail.com
State Accepted
Headers show
Series [bug#39537,v2] Add perl Config::Grammar | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll Feb. 9, 2020, 10:23 p.m. UTC
An update, forgot the (C)

Comments

Nicolas Goaziou Feb. 9, 2020, 11:12 p.m. UTC | #1
Hello,

Vincent Legoll <vincent.legoll@gmail.com> writes:

> An update, forgot the (C)
>
> -- 
> Vincent Legoll
>
> From 73dde6125142ddb6d4cae180f5d150b76a9dfd7e Mon Sep 17 00:00:00 2001
> From: Vincent Legoll <vincent.legoll@gmail.com>
> Date: Sun, 9 Feb 2020 23:01:58 +0100
> Subject: [PATCH] gnu: perl: Add  perl Config::Grammar CPAN module

I fixed the commit message, added two spaces after sentences in the
description, fixed the license, then applied your patch, as
1c8b70c875843b98cd0ddac366f6a9272d335a46.

Thank you!

Regards,
diff mbox series

Patch

From 73dde6125142ddb6d4cae180f5d150b76a9dfd7e Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sun, 9 Feb 2020 23:01:58 +0100
Subject: [PATCH] gnu: perl: Add  perl Config::Grammar CPAN module

* gnu/packages/perl.scm (perl-config-grammar): New variable.
---
 gnu/packages/perl.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9fc3493a5d..654c0858ae 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019 Stephen J. Scheck <sscheck@cpan.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1380,6 +1381,25 @@  parser in your Perl programme and allows sharing configuration files between
 languages.")
     (license bsd-3)))
 
+(define-public perl-config-grammar
+  (package
+    (name "perl-config-grammar")
+    (version "1.13")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DS/DSCHWEI/"
+                           "Config-Grammar-" version ".tar.gz"))
+       (sha256
+        (base32 "1qynf5bk6mnk90nggm3z8rdz2535kmqg46s0vj93pi68r6ia7cx8"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Config-Grammar")
+    (synopsis "Grammar-based config parser")
+    (description
+     "Config::Grammar is a module to parse configuration files. The configuration
+may consist of multiple-level sections with assignments and tabular data.")
+    (license perl)))
+
 (define-public perl-config-any
   (package
     (name "perl-config-any")
-- 
2.25.0