diff mbox series

[bug#39731,v2] gnu: benchmark: Add bonnie++

Message ID CAEwRq=pd3FUm6L08NA0jJDMUc6UkPvxSyEw4yNXyomx+YA5e3g@mail.gmail.com
State Accepted
Headers show
Series [bug#39731,v2] gnu: benchmark: Add bonnie++ | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll Feb. 24, 2020, 7:16 p.m. UTC
Forgot the (C) (again)...

Comments

Marius Bakke Feb. 26, 2020, 8:46 p.m. UTC | #1
Vincent Legoll <vincent.legoll@gmail.com> writes:

> From 8b572b851f8b41b8d344cd8b8040c8f62ac6dd27 Mon Sep 17 00:00:00 2001
> From: Vincent Legoll <vincent.legoll@gmail.com>
> Date: Sat, 22 Feb 2020 00:37:23 +0100
> Subject: [PATCH] gnu: benchmark: Add bonnie++.
>
> * gnu/packages/benchmark.scm (bonnie++): New variable.

Applied, thanks!

It was difficult to find license information, so I added a small
comment about it.
diff mbox series

Patch

From 8b572b851f8b41b8d344cd8b8040c8f62ac6dd27 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sat, 22 Feb 2020 00:37:23 +0100
Subject: [PATCH] gnu: benchmark: Add bonnie++.

* gnu/packages/benchmark.scm (bonnie++): New variable.
---
 gnu/packages/benchmark.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 602681ac86..9a30d6952f 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,6 +36,7 @@ 
   #:use-module (gnu packages linux)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mpi)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-science)
   #:use-module (gnu packages python-xyz)
@@ -231,3 +233,28 @@  This can give a much better understanding of the command's performance.")
      "Benchmark is a library to benchmark code snippets,
 similar to unit tests.")
     (license license:asl2.0)))
+
+(define-public bonnie++
+  (package
+    (name "bonnie++")
+    (version "1.98")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.coker.com.au/bonnie++/bonnie++-"
+                                  version ".tgz"))
+              (sha256
+               (base32
+                "010bmlmi0nrlp3aq7p624sfaj5a65lswnyyxk3cnz1bqig0cn2vf"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("perl" ,perl)))
+    (arguments '(#:tests? #f)) ; there are no tests
+    (home-page "https://doc.coker.com.au/projects/bonnie/")
+    (synopsis "Hard drive and file system benchmark suite")
+    (description
+     "Bonnie++ is a benchmark suite that is aimed at performing a number of
+simple tests of hard drive and file system performance.  Bonnie++ allows you to
+benchmark how your file systems perform with respect to data read and write
+speed, the number of seeks that can be performed per second, and the number of
+file metadata operations that can be performed per second.")
+    (license license:gpl2)))
-- 
2.25.1