diff mbox series

[bug#67272] gnu: Add emacs-zop-to-char.

Message ID CAEtmmez0HUo-7CiPSepXQJ6e1WBH7WiwX_k21iS==4_f39CC-w@mail.gmail.com
State New
Headers show
Series [bug#67272] gnu: Add emacs-zop-to-char. | expand

Commit Message

Rostislav Svoboda Nov. 20, 2023, 12:26 p.m. UTC
Hello,

> > +      (description "A visual zap-to-char command for Emacs.")
> "The description of a package should at least be a meaningful English sentence."

The original zap-to-char doesn't provide much. The enhancement - our
zop-to-char doesn't improve the situation either.
The same goes for zap-up-to-char and zop-up-to-char. So asking me to
come up with one is... sigh, anyway here you go.

> > +      (synopsis "A visual zap-to-char command for Emacs")
> The synopsis shouldn't start with an article, here "A".

Fixed. Sorryyyyyyyy.

> You may want to use guix lint to double-check this.

I did and... hmm looks like it's time to visit the ophthalmologist again.

I reworked the patch and I'm resending it in the attachment.

Cheers

Comments

Liliana Marie Prikler Nov. 20, 2023, 7:24 p.m. UTC | #1
Am Montag, dem 20.11.2023 um 13:26 +0100 schrieb Rostislav Svoboda:

> +(define-public emacs-zop-to-char
> +  (let ((commit "00152aa666354b27e56e20565f186b363afa0dce")
> +        (revision "0"))
> +    (package
> +      (name "emacs-zop-to-char")
> +      (version (git-version "1.1" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url
> "https://github.com/thierryvolpiatto/zop-to-char")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> "1s4adi9hyhxn7ynx195mgg10h817hxdmlzlp09633bj0llr1mjn3"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://github.com/thierryvolpiatto/zop-to-char")
> +      (synopsis "Visual @code{zap-to-char}-related commands for
> Emacs")
> +      (description
> +       "Visually enhanced versions of @code{zap-to-char} and
> +@code{zap-to-up-char}.
Still not sentence.

>   Precise character-level navigation and editing across the
> +buffer, facilitating efficient deletion, replacement, and jumping to
> specific
> +locations.")
Not sentence either.

Cheers
diff mbox series

Patch

From 96f67003b0e7b6abc193105c38e18bc94818e4c8 Mon Sep 17 00:00:00 2001
Message-ID: <96f67003b0e7b6abc193105c38e18bc94818e4c8.1700482998.git.Rostislav.Svoboda@gmail.com>
From: Rostislav Svoboda <Rostislav.Svoboda@gmail.com>
Date: Sun, 19 Nov 2023 10:50:57 +0100
Subject: [PATCH] gnu: Add emacs-zop-to-char.

* gnu/packages/emacs-xyz.scm (emacs-zop-to-char): New variable.

Change-Id: I7722fd0d8b6425ea0d16af9ab2d36396ead6e309
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2b096fcb24..1b5a977e15 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -38763,6 +38763,31 @@  (define-public emacs-totp
 variations, including non-standard base32 encodings.")
        (license license:gpl3+))))
 
+(define-public emacs-zop-to-char
+  (let ((commit "00152aa666354b27e56e20565f186b363afa0dce")
+        (revision "0"))
+    (package
+      (name "emacs-zop-to-char")
+      (version (git-version "1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/thierryvolpiatto/zop-to-char")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1s4adi9hyhxn7ynx195mgg10h817hxdmlzlp09633bj0llr1mjn3"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/thierryvolpiatto/zop-to-char")
+      (synopsis "Visual @code{zap-to-char}-related commands for Emacs")
+      (description
+       "Visually enhanced versions of @code{zap-to-char} and
+@code{zap-to-up-char}.  Precise character-level navigation and editing across the
+buffer, facilitating efficient deletion, replacement, and jumping to specific
+locations.")
+      (license license:gpl3+))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar

base-commit: 71b92466430acb8c91841522dc0eb7d766af4388
prerequisite-patch-id: fffccc797bda74d3b25e987538ff5b916e0e976f
prerequisite-patch-id: 79914a97779bed9904a1d80e56fa0339eccaf329
-- 
2.41.0