diff mbox series

[bug#66562] gnu: emacs-haskell-snippets: Fix haskell-snippets-dir value.

Message ID CAEtmmeyLJHWVwff02yjpJV7A9kUrjJZL0j17dXFioaazezaGvA@mail.gmail.com
State New
Headers show
Series [bug#66562] gnu: emacs-haskell-snippets: Fix haskell-snippets-dir value. | expand

Commit Message

Rostislav Svoboda Oct. 15, 2023, 5:21 p.m. UTC
> > +                (emacs-substitute-sexps "haskell-snippets.el"
> > +                  ("setq haskell-snippets-dir"
> > +                   '(file-name-parent-directory
> > +                     (file-name-directory load-file-name))))))
> There is actually a substitute-sexps specialization for variables.
> Perhaps use that instead?

The emacs-substitute-variables doesn't work since haskell-snippets-dir
is defined using setq, not defcustom, hence I used the
emacs-substitute-sexps.

> > * gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): Fix
> > haskell-snippets-dir value
> >
> > The value of haskell-snippets-dir was:
> >   /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-
> > lisp/haskell-snippets-*/
> > It needs to be:
> >   /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-lisp/
> >
> > The error was (abbreviated):
> > No such file or directory, /gnu/store/*-emacs-haskell-snippets-
> > */share/emacs/site-lisp/haskell-snippets-*/snippets
>
> Explanations go above the ChangeLog.

Ok, I changed that. See the patch in the attachment.

Cheers
diff mbox series

Patch

From ad1db1742216054abd406988b6ce9b3bb5cb18ec Mon Sep 17 00:00:00 2001
Message-ID: <ad1db1742216054abd406988b6ce9b3bb5cb18ec.1697390351.git.Rostislav.Svoboda@gmail.com>
From: Rostislav Svoboda <Rostislav.Svoboda@gmail.com>
Date: Sun, 15 Oct 2023 17:04:57 +0200
Subject: [PATCH] gnu: emacs-haskell-snippets: Fix haskell-snippets-dir value.

The error is (abbreviated):
No such file or directory, /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-lisp/haskell-snippets-*/snippets

The value of haskell-snippets-dir was:
  /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-lisp/haskell-snippets-*/
It needs to be:
  /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-lisp/

* gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): Fix
haskell-snippets-dir value
---
 gnu/packages/emacs-xyz.scm | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb8c25f9b5..8bb0d6d43a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35545,6 +35545,12 @@  (define-public emacs-haskell-snippets
        (list
         #:phases
         #~(modify-phases %standard-phases
+            (add-after 'unpack 'patch-haskell-snippets-dir
+              (lambda* (#:key outputs #:allow-other-keys)
+                (emacs-substitute-sexps "haskell-snippets.el"
+                  ("setq haskell-snippets-dir"
+                   '(file-name-parent-directory
+                     (file-name-directory load-file-name))))))
             (add-after 'install 'install-snippets
               (lambda _
                 (let ((snippets

base-commit: a0d2ecde943bd1854ddbb7c0cad35a1fc64dc5ab
-- 
2.41.0