Hardcode version in `emacs-next', use commit in `file-name'
* gnu/packages/emacs.scm (emacs-next):
Hardcode version to be 27.0.50.
Change file-name to use commit instead of version to avoid checkout collisions.
@@ -221,7 +221,7 @@ languages.")
(package
(inherit emacs)
(name "emacs-next")
- (version (git-version "27" revision commit))
+ (version "27.0.50")
(source
(origin
(method git-fetch)
@@ -229,7 +229,7 @@ languages.")
(url "https://git.savannah.gnu.org/git/emacs.git")
(commit commit)))
(sha256 (base32 "0niamywp3cq05hqc7k693c3d12jbqbzbfgl4aza9dja0jidv4b80"))
- (file-name (git-file-name name version))
+ (file-name (git-file-name name commit))
(patches (search-patches "emacs27-exec-path.patch"
"emacs-fix-scheme-indent-function.patch"
"emacs-source-date-epoch.patch"))