diff mbox series

[bug#39397] Add Alacritty and many Rust dependencies

Message ID CADXmXki1QwVSqALouqHF-EF=2z7CgAVD+upanwA+enxpnYzEOw@mail.gmail.com
State Accepted
Headers show
Series [bug#39397] Add Alacritty and many Rust dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Valentin Ignatev Feb. 2, 2020, 8:46 p.m. UTC
Hey Guix!

Here's Alacritty 0.4.1 and many Rust dependencies that it requires
directly and transitively. I've tried to make patches in topological
order but might've screwed that order up because I had to rebase many
of them on top of master couple times.

I also cut a couple corners in that I haven't packaged all glium
version down to 0.11 because the latest glium has cyclig dev
dependencies on many of its previous versions through cgmath. I left a
todo comment though.

Also I hope I didn't messed up a patch sending workflow, it's the
first time I'm doing it this way.

Valentin

Comments

Valentin Ignatev Feb. 2, 2020, 9:16 p.m. UTC | #1
For convenience, here's my local guix mirror with those patches
applied to master: https://github.com/valignatev/guix

Valentin
Efraim Flashner Feb. 27, 2020, 2:39 p.m. UTC | #2
On Mon, Feb 03, 2020 at 12:16:36AM +0300, Valentin Ignatev wrote:
> For convenience, here's my local guix mirror with those patches
> applied to master: https://github.com/valignatev/guix
> 
> Valentin

Overall it looks good. I had a small problem with rust-andrew-0.2
missing for a couple of commits but it wasn't too bad. I ended up
dropping the rust pnactl package since it bundled libressl and wasn't
being maintained.

For alacritty I worked around the winit-0.20 issue by upgrading it to
0.20, since the commit they chose was 1 commit after 0.20-alpha6. I
wasn't able to test it since my machine only goes up to OpenGL 2.0 or
2.1 and alacritty needs 3.2.

I'll finish pushing the last of the patches very soon.
Valentin Ignatev Feb. 27, 2020, 3:41 p.m. UTC | #3
Wow, thanks a lot for such a hard work!

Valentin
diff mbox series

Patch

From 62d6ad5f4488940319b761eeca1e17119af1f435 Mon Sep 17 00:00:00 2001
From: Valentin Ignatev <valentignatev@gmail.com>
Date: Wed, 15 Jan 2020 03:04:28 +0300
Subject: [PATCH 001/275] gnu: Add rust-compiler-error-0.1.

* gnu/packages/crates-io.scm (rust-compiler-error-0.1): New variable.
---
 gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a5f224f99e..5983993694 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1603,6 +1603,27 @@  need compiler-rt intrinsics.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-compiler-error-0.1
+  (package
+    (name "rust-compiler-error")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "compiler_error" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0irh7c0gznk2k6mj3cmqw7x4pg59lppmy1y8d6k5xc926rnmz5zg"))))
+    (build-system cargo-build-system)
+    (arguments '(#:skip-build? #t))
+    (home-page
+     "https://github.com/lu-zero/compiler_error")
+    (synopsis "Triggerable compiler error")
+    (description "Triggerable compiler error")
+    (license license:expat)))
+
 (define-public rust-compiletest-rs-0.3
   (package
     (name "rust-compiletest-rs")
-- 
2.25.0