diff mbox series

[bug#62262] Add xfishtank and xpenguins

Message ID CADBZEV=J2uCKptpyweZLh8=vXrKtg9=PHwwH4wdOMCfr4D51rg@mail.gmail.com
State New
Headers show
Series [bug#62262] Add xfishtank and xpenguins | expand

Commit Message

Sarthak Shah March 18, 2023, 4:27 p.m. UTC
Hi Guix,
This patch adds xfishtank and xpenguins to toys.scm which are programs
similar to xsnow by the same author.

* gnu/packages/toys.scm (xpenguins): New variable.
* gnu/packages/toys.scm (xfishtank): New variable.
---
 gnu/packages/toys.scm | 64 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 64 insertions(+)

+
 (define-public nyancat
   (package
     (name "nyancat")

Comments

Greg Hogan May 16, 2023, 6:26 p.m. UTC | #1
On Sat, Mar 18, 2023 at 12:28 PM Sarthak Shah <shahsarthakw@gmail.com> wrote:
>
> Hi Guix,
> This patch adds xfishtank and xpenguins to toys.scm which are programs similar to xsnow by the same author.

The packages build and run as expected. This single patch should be
separated into a patch per package.

> * gnu/packages/toys.scm (xpenguins): New variable.
> * gnu/packages/toys.scm (xfishtank): New variable.
> ---
>  gnu/packages/toys.scm | 64 +++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 64 insertions(+)
>
> diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
> index 8967c0c25b..16adf6d92a 100644
> --- a/gnu/packages/toys.scm
> +++ b/gnu/packages/toys.scm
> @@ -397,6 +397,70 @@ (define-public xsnow
>  and various scenery elements.")
>      (license license:gpl3+)))
>
> +(define-public xpenguins
> +  (package
> +    (name "xpenguins")
> +    (version "3.2.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
> +             version ".tar.gz"))
> +       (sha256
> +        (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     '(#:phases
> +       (modify-phases %standard-phases
> +         (add-before 'configure 'fix-install-path
> +           (lambda _
> +             ;; Install program to bin instead of games.
> +             (substitute* "src/Makefile.in"
> +               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
> +                (string-append prefix "bin")))
> +             #t)))))

It was my understanding that there is no need to return true. Same below.

> +    (inputs
> +     (list gtk+ libx11 libxpm libxt libxml2))
> +    (native-inputs
> +     (list pkg-config))
> +    (home-page "https://www.ratrabbit.nl/ratrabbit/xpenguins/index.html")

I am getting redirected and the new URL looks to be
https://www.ratrabbit.nl/ratrabbit/software/xpenguins

> +    (synopsis "Let penguins take over your desktop!")
> +    (description "@code{Xpenguins} is a vintage application for Unix systems, showing penguins running, flying, falling etc. on the desktop, using windows as run paths.")
> +    (license license:gpl3+)))

I am finding gpl2+ in xpenguins-3.2.1/COPYING

> +
> +(define-public xfishtank
> +  (package
> +    (name "xfishtank")
> +    (version "3.1.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +              "https://ratrabbit.nl/downloads/xfishtank/xfishtank-"
> +             version ".tar.gz"))
> +       (sha256
> +        (base32 "0jbx41kdpgm3nrnrvfy9znkipd8xq0jj5plavcsjkhkva8ybc0ax"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     '(#:phases
> +       (modify-phases %standard-phases
> +         (add-before 'configure 'fix-install-path
> +           (lambda _
> +             ;; Install program to bin instead of games.
> +             (substitute* "src/Makefile.in"
> +               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
> +                (string-append prefix "bin")))
> +             #t)))))
> +    (inputs
> +     (list gtk+ libx11 libxpm libxt libxml2))
> +    (native-inputs
> +     (list pkg-config))
> +    (home-page "https://www.ratrabbit.nl/ratrabbit/xfishtank")

Same issue with redirection, with the new URL
https://www.ratrabbit.nl/ratrabbit/software/xfishtank

> +    (synopsis "Let fishes swim over your desktop!")
> +    (description "@code{Xfishtank} is a well-known vintage application for Unix systems, based on the X11 protocol. It shows fishes swimming over the desktop.")
> +    (license license:gpl3+)))

COPYING is gpl3 but the files are MIT licensed.

> +
>  (define-public nyancat
>    (package
>      (name "nyancat")
> --
> 2.39.1
>
Steve George Feb. 17, 2024, 5:12 p.m. UTC | #2
Review:
  * Updated xfishtank to latest upstream 3.2.1
  * Added Reviewed-by commit trailers (Greg / Steve)
  * Applied patches, test installed, linted
  * Re-roll to trigger QA build

Sarthak Shah (2):
  gnu: Add xpenguins.
  gnu: Add xfishtank.


 gnu/packages/toys.scm | 69 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 69 insertions(+)


base-commit: 06014750338159a03a6374d7ebdd783c210b3715
Steve George Feb. 18, 2024, 12:25 p.m. UTC | #3
usertag 62262 reviewed-looks-good
quit
Clément Lassieur Feb. 20, 2024, 12:07 a.m. UTC | #4
Hi Steve,

My understanding is that you should write

    user guix

before the usertag line, so that it is associated with the 'guix' user.

https://guix.gnu.org/manual/en/html_node/Debbugs-Usertags.html

On Sun, Feb 18 2024, Steve George wrote:

> usertag 62262 reviewed-looks-good
> quit

Cheers

Clément
Nicolas Goaziou Feb. 22, 2024, 7:48 p.m. UTC | #5
Hello,

Steve George <steve@futurile.net> writes:

>   * Updated xfishtank to latest upstream 3.2.1
>   * Added Reviewed-by commit trailers (Greg / Steve)
>   * Applied patches, test installed, linted
>   * Re-roll to trigger QA build

I slightly tweaked the descriptions and applied your patches.

Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 8967c0c25b..16adf6d92a 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -397,6 +397,70 @@  (define-public xsnow
 and various scenery elements.")
     (license license:gpl3+)))

+(define-public xpenguins
+  (package
+    (name "xpenguins")
+    (version "3.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-install-path
+           (lambda _
+             ;; Install program to bin instead of games.
+             (substitute* "src/Makefile.in"
+               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+                (string-append prefix "bin")))
+             #t)))))
+    (inputs
+     (list gtk+ libx11 libxpm libxt libxml2))
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://www.ratrabbit.nl/ratrabbit/xpenguins/index.html")
+    (synopsis "Let penguins take over your desktop!")
+    (description "@code{Xpenguins} is a vintage application for Unix
systems, showing penguins running, flying, falling etc. on the desktop,
using windows as run paths.")
+    (license license:gpl3+)))
+
+(define-public xfishtank
+  (package
+    (name "xfishtank")
+    (version "3.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+              "https://ratrabbit.nl/downloads/xfishtank/xfishtank-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "0jbx41kdpgm3nrnrvfy9znkipd8xq0jj5plavcsjkhkva8ybc0ax"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-install-path
+           (lambda _
+             ;; Install program to bin instead of games.
+             (substitute* "src/Makefile.in"
+               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+                (string-append prefix "bin")))
+             #t)))))
+    (inputs
+     (list gtk+ libx11 libxpm libxt libxml2))
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://www.ratrabbit.nl/ratrabbit/xfishtank")
+    (synopsis "Let fishes swim over your desktop!")
+    (description "@code{Xfishtank} is a well-known vintage application for
Unix systems, based on the X11 protocol. It shows fishes swimming over the
desktop.")
+    (license license:gpl3+)))