diff mbox series

[bug#62087] Add texlive-onedown

Message ID CACSMDjNDd=L_gLxBUaYyWVvcoubtXXMF_ThLYeoxu4Zco5=eKw@mail.gmail.com
State New
Headers show
Series [bug#62087] Add texlive-onedown | expand

Commit Message

ABHINAV C YADAV March 9, 2023, 2:25 p.m. UTC
Hello,
I made a patch to add texlive-onedown support to GUIX

Comments

Nicolas Goaziou March 12, 2023, 6:53 p.m. UTC | #1
Hello,

ABHINAV C YADAV <acyadav805@gmail.com> writes:

> I made a patch to add texlive-onedown support to GUIX

Thank you.

However, I think this is a bogus patch.

Closing.

Regards,
diff mbox series

Patch

From 7687c02ad5894e4e696a9ea5bd59e2797ad89321 Mon Sep 17 00:00:00 2001
From: abhi-abhinav <acyadav805@gmail.com>
Date: Thu, 9 Mar 2023 19:46:43 +0530
Subject: [PATCH] Add texlive-onedown

---
 gnu/packages/tex.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f178bafcc2..67a4297b13 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3454,6 +3454,7 @@  (define-public texlive-hyperref
              texlive-latex-refcount
              texlive-latex-rerunfilecheck
              texlive-url
+	     texlive-onedown
              texlive-cm
              texlive-latex-graphics     ;for keyval
              texlive-stringenc
@@ -3528,6 +3529,7 @@  (define-public texlive-latex-rerunfilecheck
 files have changed.  It is based on MD5 checksum, provided by pdfTeX.")
     (license license:lppl1.3c+)))
 
+
 (define-public texlive-latex-tools
   (package
     (name "texlive-latex-tools")
@@ -3566,6 +3568,24 @@  (define-public texlive-latex-tools
 xr, and xspace.")
     (license license:lppl1.3+)))
 
+(define-public texlive-onedown
+  (package
+    (name "texlive-onedown")
+    (version "2021")
+    (source (origin
+              (method url-fetch)
+              (uri (texlive-tlpdb-uri version))
+              (sha256 (texlive-tlpdb-sha256 version))))
+    (build-system texlive-build-system)
+    (synopsis "Move the current section down one level")
+    (description
+     "This package provides the command \\onecolumndown,
+which moves the current section down one level.")
+    (home-page "https://www.ctan.org/pkg/onedown")
+    (license license:lppl1.3)))
+
+
+
 (define-public texlive-url
   (package
     (inherit (simple-texlive-package
-- 
2.37.2