From c18e9f29051ed0e987e01f53abbd71c7bdb3a2a8 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Mon, 18 Jan 2021 19:27:43 +0300
Subject: [PATCH] gnu: Add obs-wlrobs.
* gnu/packages/video.scm (obs-wlrobs): New variable.
---
gnu/packages/video.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -47,6 +47,7 @@
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
+;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,6 +74,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix svn-download)
+ #:use-module (guix hg-download)
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
@@ -3133,6 +3135,34 @@ and JACK.")
(home-page "https://obsproject.com")
(license license:gpl2+)))
+(define-public obs-wlrobs
+ (package
+ (name "obs-wlrobs")
+ (version "1.0")
+ (source
+ (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://hg.sr.ht/~scoopta/wlrobs")
+ (changeset (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1faiq2gdb7qis3m1hilm4pz8lkmkab75vzm608dbiazahhybf96p"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs `() )
+ (inputs `(("obs" ,obs)
+ ("libx11" ,libx11 "out")
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://hg.sr.ht/~scoopta/wlrobs")
+ (synopsis "Plugin for @code{obs} for Wayland (wlroots) screen capture")
+ (description "Allows to capture the screen on wlroots based wayland
+compositors.")
+ (license license:gpl3)))
+
(define-public libvdpau
(package
(name "libvdpau")
--
2.30.0