diff mbox series

[bug#45960] gnu: Add obs-spectralizer.

Message ID CABrWRW316DAGt6WF6ogwiYDdEgWKVyPCRx8fOuCmteNqE5HAGQ@mail.gmail.com
State Accepted
Headers show
Series [bug#45960] gnu: Add obs-spectralizer. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin Jan. 18, 2021, 4:57 p.m. UTC

Comments

Ludovic Courtès Feb. 2, 2021, 9:34 a.m. UTC | #1
Hi,

Andrew Tropin <andrew@trop.in> skribis:

> From cf3a2cf54a17e131dcd57a1fb280d3586521c500 Mon Sep 17 00:00:00 2001
> From: Andrew Tropin <andrew@trop.in>
> Date: Mon, 18 Jan 2021 19:39:44 +0300
> Subject: [PATCH] gnu: Add obs-spectralizer.
>
> * gnu/packages/video.scm (obs-spectralizer): New variable.

Applied!  I didn’t check whether OBS can actually load it, but I see
it’s installed under ‘lib/obs-plugins’, which is where the new search
path expects to find it, so it should be fine.

Thanks,
Ludo’.
Andrew Tropin Feb. 2, 2021, 9:53 a.m. UTC | #2
Very nice! Thank you!

It won't load until obs updated to the commit with OBS_PLUGINS*_PATH
variables support [fn:1], but as you said it's future-proof and already
installs to the correct location.

There is another very similar patch, which adds another obs plugin. You
probably already aware of it, but here is a link:
http://issues.guix.gnu.org/45961. Accidentally, it has empty propagated
inputs and I'm not sure if it will apply to current master at all, but I
can update it if it's needed.


* Footnotes

[fn:1] http://issues.guix.gnu.org/46113
Ludovic Courtès Feb. 3, 2021, 10:43 a.m. UTC | #3
Hi,

Andrew Tropin <andrew@trop.in> skribis:

> It won't load until obs updated to the commit with OBS_PLUGINS*_PATH
> variables support [fn:1], but as you said it's future-proof and already
> installs to the correct location.
>
> There is another very similar patch, which adds another obs plugin. You
> probably already aware of it, but here is a link:
> http://issues.guix.gnu.org/45961. Accidentally, it has empty propagated
> inputs and I'm not sure if it will apply to current master at all, but I
> can update it if it's needed.
>
>
> * Footnotes
>
> [fn:1] http://issues.guix.gnu.org/46113

Ah ha!  So on ‘master’, there’s the OBS_PLUGINS_DIRECTORY patch that you
provided earlier, which is why I wrote that the plugins should work.

Should we wait for the next OBS release instead of packaging an
arbitrary commit?

Ludo’.
ashish.is--- via Guix-patches" via Feb. 3, 2021, 2 p.m. UTC | #4
Hi,

Thanks for merging my patch =) I am not insist on keeping [1], but I do think that is more cleaner solution. 

With the upstream patch, Obs will be able to extend the list of plugin directories. We are going to add ~/.guix-profile/ to that list, which means Obs will have two different locations with partially different so files. It doesn't look clean to me. 

In addition, [1] doesn't require to have OBS_PLUGINS_DIRECTORY variables. If there is no such, it will run with its defaults.


Footnotes:
[1]  https://issues.guix.gnu.org/45707
diff mbox series

Patch

From cf3a2cf54a17e131dcd57a1fb280d3586521c500 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Mon, 18 Jan 2021 19:39:44 +0300
Subject: [PATCH] gnu: Add obs-spectralizer.

* gnu/packages/video.scm (obs-spectralizer): New variable.
---
 gnu/packages/video.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b876ef6adc..d0df1c36c1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3163,6 +3163,33 @@  and JACK.")
 compositors.")
     (license license:gpl3)))
 
+(define-public obs-spectralizer
+  (package
+    (name "obs-spectralizer")
+    (version "1.3.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/univrsal/spectralizer")
+              (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "0q75cnyqydpvfda51zm9gxqj3wqr99ad0lxzjhw0ld67qvj1ag6i"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f
+       #:configure-flags
+       (list "-DGLOBAL_INSTALLATION=ON" "-DUSE_CMAKE_LIBDIR=ON")))
+    (inputs `(("obs" ,obs)
+              ("fftw" ,fftw)))
+    (home-page "https://github.com/univrsal/spectralizer")
+    (synopsis "Plugin for @code{obs} for audio visualization")
+    (description "Allows vizualisation of MPD and internal @code{obs} audio
+sources.  Using @code{fftw}, based on cli-visualizer.")
+    (license license:gpl2)))
+
 (define-public libvdpau
   (package
     (name "libvdpau")
-- 
2.30.0