diff mbox series

[bug#44555] gnu: Add emacs-next-use-package

Message ID CABrWRW21b8OZ=5t8LVfd-W6kztr874ZH16VpG+CvGui8sp8WAw@mail.gmail.com
State Accepted
Headers show
Series [bug#44555] gnu: Add emacs-next-use-package | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Andrew Tropin Nov. 11, 2020, 7:53 a.m. UTC
Cool news: John Wiegley made a new release a few hours ago, my patch is no
longer relevant, will make another one, which just bumps the version to
2.4.1.

> Normally, we try to install optional packages per default.
> Sometimes, it's not so easy and one has to weigh up...
>
> Maybe the use-case for use-package is so that diminish is very often
> needed?  Or for too many users, it would be "useless" (or break
> something), w/o it?
>
>
> Imho (I don't have commit superpower), you need a reason to remove an
> input (and here, this means provided/out of the box experience).  Or at
> least make a comment in the source _why_ it isn't needed etc...

I will give you a simple example: Someone uses delight (a diminish
alternative, which also support major modes) instead of diminish and
they would install emacs-use-package and emacs-delight, but he will also
get emacs-diminsh as a dependency of emacs-use-package. To remove it
they will need to inherit emacs-use-package and update
propagated-inputs.

I think installing emacs-use-package and manually adding emacs-diminish
is easier and more fair than installing emacs-use-package+emacs-delight
and removing emacs-diminish from dependencies of emacs-use-package.

I totally agree, that diminish is a great package with a great story
inside its sources, but don't think it should be installed by default
with use-package.

I'll make a separate patch for removing propagated-inputs and related
discussion.

Bump patch in the attachment.

Comments

Nicolas Goaziou Nov. 11, 2020, 9:35 a.m. UTC | #1
Hello,

Andrew Tropin <andrew@trop.in> writes:

> I will give you a simple example: Someone uses delight (a diminish
> alternative, which also support major modes) instead of diminish and
> they would install emacs-use-package and emacs-delight, but he will also
> get emacs-diminsh as a dependency of emacs-use-package. To remove it
> they will need to inherit emacs-use-package and update
> propagated-inputs.

I don't understand something here. Why would you have to remove Diminsh
in order to use Delight? Can't you have both in "site-lisp" and use
whichever you want?

Regards,
Nicolas Goaziou Nov. 11, 2020, 10:02 a.m. UTC | #2
Hello,

Andrew Tropin <andrew@trop.in> writes:

> Cool news: John Wiegley made a new release a few hours ago, my patch is no
> longer relevant, will make another one, which just bumps the version to
> 2.4.1.

Applied. Thank you.

Regards,
Andrew Tropin Nov. 11, 2020, 2:33 p.m. UTC | #3
> Applied. Thank you.
Thanks a lot!

Thank you everyone for help!

--
Best regards,
Andrew Tropin
diff mbox series

Patch

From 7f725f6c1b8a0e724002ac67c5e26a8df747ad6b Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Wed, 11 Nov 2020 10:48:30 +0300
Subject: [PATCH] gnu: emacs-use-package: Update to 2.4.1

use-package 2.4 released 2 years ago and doesn't work with GNU Emacs 28.
2.4.1 contains mostly bug fixes and works with emacs-next.
---
 gnu/packages/emacs-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d27d397775..b8ab78edf8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11131,7 +11131,7 @@  abbreviation of the mode line displays (lighters) of minor modes.")
 (define-public emacs-use-package
   (package
     (name "emacs-use-package")
-    (version "2.4")
+    (version "2.4.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -11140,7 +11140,7 @@  abbreviation of the mode line displays (lighters) of minor modes.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1b7mjjh0d6fmkkd9vyj64vca27xqhga0nvyrrcqxpqjn62zq046y"))))
+                "088kl3bml0rs5bkfymgzr15ram9qvy66h1kaisrbkynh0yxvf8g9"))))
     (build-system emacs-build-system)
     (native-inputs
      `(("texinfo" ,texinfo)))
-- 
2.25.4