diff mbox series

[bug#64761] gnu: odamex: Update to 10.3.0.

Message ID CAB3eSakD5p+Gr5bBmr_--bu3Qh=Pfx4th24MAFKzJBKnYejLLg@mail.gmail.com
State New
Headers show
Series [bug#64761] gnu: odamex: Update to 10.3.0. | expand

Commit Message

David Pflug July 21, 2023, 12:41 a.m. UTC
* gnu/packages/games.scm (odamex): Update to 10.3.0
---
 gnu/packages/games.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Sharlatan Hellseher Feb. 10, 2024, 4:07 p.m. UTC | #1
Hi,

Update to 10.3.0 pushed as 6aefab6c0c5e9656572ce0ad8d9d41e27cb17071 to master.

I've unbundled some libs, but more work required to proper replace remaining
bundled libraries.

Unbundle some libs and remove labels pushed as 54592df80d..6a59d3ad68 to
master.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ec084553da..6a34693a0c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -60,7 +60,7 @@ 
 ;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
-;;; Copyright © 2021 David Pflug <david@pflug.io>
+;;; Copyright © 2021, 2023 David Pflug <david@pflug.io>
 ;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021, 2022 Noisytoot <ron@noisytoot.org>
@@ -7879,19 +7879,20 @@  (define-public gzdoom
 (define-public odamex
   (package
     (name "odamex")
-    (version "0.9.5")
+    (version "10.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "mirror://sourceforge/odamex/Odamex/" version "/"
-             "odamex-src-" version ".tar.bz2"))
+             "odamex-src-" version ".tar.zstd"))
        (sha256
-        (base32 "1x0c9vnwn336inkfamh4na8xjyfjmzfxfn49j4snqymkypjqw6jq"))))
+        (base32 "1wws74hrc816raj9wbwmhi7q1arzjv0fxssdgbyppy0zh7zg5abh"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f))          ; no tests
     (native-inputs
-     (list deutex))
+     (list deutex
+           zstd))
     (inputs
      `(("sdl" ,sdl2)
        ("sdl-mixer" ,sdl2-mixer)