[bug#34963] Add emacs-prescient

Message ID CAAc=MEzy66c4T0Jmq-ecL2QzQwqWxBvUdsBQn7QvSNHNQ0pyFQ@mail.gmail.com
State Accepted
Headers show
Series [bug#34963] Add emacs-prescient | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung March 24, 2019, 12:03 a.m. UTC
See attached.

Comments

Ludovic Courtès March 25, 2019, 9:38 a.m. UTC | #1
Brian Leung <bkleung89@gmail.com> skribis:

> From df74f04ba2adb1e2e9067ec453647c767d9b8c48 Mon Sep 17 00:00:00 2001
> From: Brian Leung <bkleung89@gmail.com>
> Date: Sun, 24 Mar 2019 00:59:47 +0100
> Subject: [PATCH] gnu: Add emacs-prescient.
>
> * gnu/packages/emacs-xyz.scm (emacs-prescient): New variable.

[...]

> +    (synopsis "A library that sorts and filters lists of candidates")

I removed the “A” as ‘guix lint’ suggested :-) and committed, thanks!

Patch

From df74f04ba2adb1e2e9067ec453647c767d9b8c48 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sun, 24 Mar 2019 00:59:47 +0100
Subject: [PATCH] gnu: Add emacs-prescient.

* gnu/packages/emacs-xyz.scm (emacs-prescient): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f040b2b07..e30df67e9e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3535,6 +3535,31 @@  of sixteen colors suitable for a wide range of applications.  Base16 is not a
 single theme but a set of guidelines with numerous implementations.")
     (license license:expat)))
 
+(define-public emacs-prescient
+  (package
+    (name "emacs-prescient")
+    (version "2.2.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/raxod502/prescient.el/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1ncplx5p3cffyzg9ygzqqxj0vpvwrz9rp2n4z6c375a78fyydrk0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-company" ,emacs-company)
+       ("emacs-ivy" ,emacs-ivy)))
+    (home-page "https://github.com/raxod502/prescient.el/")
+    (synopsis "A library that sorts and filters lists of candidates")
+    (description
+     "This package provides a library for sorting and filtering, as well as
+extensions for @code{ivy-mode} and @code{company-mode} that make use of the
+library.")
+    (license license:gpl3+)))
+
 (define-public emacs-smartparens
   (package
     (name "emacs-smartparens")
-- 
2.21.0