diff mbox series

[bug#37081] Add emacs-org-auto-expand.

Message ID CAAc=MEzqSHOoYKGDm89vqSqp5qTTF=Xmh=swej0dAqcT+A_PWw@mail.gmail.com
State Accepted
Headers show
Series [bug#37081] Add emacs-org-auto-expand. | expand

Commit Message

Brian Leung Aug. 19, 2019, 7 a.m. UTC
See attached.

Comments

Oleg Pykhalov Aug. 19, 2019, 9 p.m. UTC | #1
Hello Brian,

Thank you.  Pushed to master.

Oleg.
diff mbox series

Patch

From 58395cc1dd10736b0fdcdd396f99c1a2389375ca Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 13 Aug 2019 02:34:30 +0200
Subject: [PATCH] gnu: Add emacs-org-auto-expand.

* gnu/packages/emacs-xyz.scm (emacs-org-auto-expand): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ffc662f746..f170c1147c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10951,6 +10951,31 @@  tables of contents.")
 files, allowing for actions to be performed based on search criteria.")
     (license license:gpl3+)))
 
+(define-public emacs-org-auto-expand
+  (let ((commit "4938d5f6460e2f8f051ba9ac000b291bfa43ef62")
+        (revision "1"))
+    (package
+      (name "emacs-org-auto-expand")
+      (version (git-version "0.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/alphapapa/org-auto-expand")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1my0c6xmkh37lwi6l472lz9d86lf20h6xcllzlxm1lxa24rhva6v"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-org" ,emacs-org)
+         ("emacs-dash" ,emacs-dash)))
+      (home-page "https://github.com/alphapapa/org-auto-expand")
+      (synopsis "Automatically expand certain Org headings")
+      (description "This package allows a customizable set of headings in Org
+files to be expanded upon opening them.")
+      (license license:gpl3+))))
+
 (define-public emacs-parsebib
   (package
     (name "emacs-parsebib")
-- 
2.23.0