[bug#34598] Guix patch: emacs-isearch-plus

Message ID CAAc=MEzq=a+9iD0u7Dkn0_gsN1iu0Tsnr+6V4RptMB=ZR3yqyg@mail.gmail.com
State Accepted
Headers show
Series [bug#34598] Guix patch: emacs-isearch-plus | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung Feb. 21, 2019, 12:14 a.m. UTC
See attached.

Comments

Brian Leung Feb. 28, 2019, 1:43 a.m. UTC | #1
I suspect this may have been mistaken for a duplicate since I submitted a
recipe for a similar package recently. To be clear, this is a different
package; that other one is also for `isearch`, but provides slightly
different functionality from this package.
Ricardo Wurmus March 3, 2019, 2:41 p.m. UTC | #2
Hi Brian,

sorry for the delay!

I just pushed your patch with commit d2f555f59b with the following changes:

- I added a copyright line to the top of the file.
- I changed the description to use full sentences.
- I renamed the package to “emacs-isearch+”.

Thanks for your contribution!

Patch

From 70738eede8a187d01dc1b45b47971eea2342f19c Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Thu, 21 Feb 2019 01:12:25 +0100
Subject: [PATCH] gnu: Add emacs-isearch-plus.
To: guix-patches@gnu.org

From: leungbk <bkleung89@gmail.com>

---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cedc1efbc8..9c562d32d4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11129,6 +11129,29 @@  my_thing reload} all the time.  It offers a consistent UI over different init
 systems.")
     (license license:gpl3+)))
 
+(define-public emacs-isearch-plus
+  (let ((commit "95e49af9dbf0254e095a11f115e101b52659520a")
+        (revision "1"))
+    (package
+      (name "emacs-isearch-plus")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsmirror/isearch-plus.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0xhd9zgknf4lvzyf4apirpd7spb1hbpzkvys00a7pkmd0vvahk0v"))))
+      (build-system emacs-build-system)
+      (home-page "https://www.emacswiki.org/emacs/isearch+.el")
+      (synopsis "Extensions to @code{isearch.el}")
+      (description "Extend @code{isearch} with advice, dynamic filters,
+highlighting of regexp group levels, and more.")
+      (license license:gpl2+))))
+
 (define-public emacs-esh-autosuggest
   (package
     (name "emacs-esh-autosuggest")
-- 
2.20.1