diff mbox series

[bug#36326] Add Haskell packages.

Message ID CAAc=MEzby+Ne_Kcek6sWDk5fbiZgx=YOpsxoNa4Y1hP63sT1Lg@mail.gmail.com
State Accepted
Headers show
Series [bug#36326] Add Haskell packages. | expand

Commit Message

Brian Leung June 26, 2019, 4:09 p.m. UTC
Sorry, I didn't see the entirety of the lint result when I last wrote. I've
fixed everything up. The linter should choke on ghc-hindent, which is fine
since it's an upstream problem with the latest release (the .cabal file has
improper indentation).

On Sun, Jun 23, 2019 at 12:49 AM Brian Leung <bkleung89@gmail.com> wrote:

> Hi,
>
> OK, I've linted and added another package. Please ignore my last email.
>

Comments

Brian Leung July 12, 2019, 12:37 a.m. UTC | #1
Friendly ping.

On Wed, Jun 26, 2019 at 6:09 PM Brian Leung <bkleung89@gmail.com> wrote:

> Sorry, I didn't see the entirety of the lint result when I last wrote.
> I've fixed everything up. The linter should choke on ghc-hindent, which is
> fine since it's an upstream problem with the latest release (the .cabal
> file has improper indentation).
>
> On Sun, Jun 23, 2019 at 12:49 AM Brian Leung <bkleung89@gmail.com> wrote:
>
>> Hi,
>>
>> OK, I've linted and added another package. Please ignore my last email.
>>
>
Timothy Sample July 17, 2019, 2:21 p.m. UTC | #2
Hi Brian,

Brian Leung <bkleung89@gmail.com> writes:

> Friendly ping.

I looked over the patches and they look pretty good in general.  There’s
just one little thing, which I realize is a little annoying.  We try to
follow the Stackage LTS versions of packages where possible, as they are
chosen carefully to work together and with our version of GHC (8.4.3).
Right now, we are on Stackge LTS 12.14.  Could you please go over these
patches and downgrade them to their Stackage LTS 12.14 versions (which
can be found at <https://www.stackage.org/lts-12.14>)?  You can also
import directly from Stackage, using (for example):

    guix import stackage --lts-version=12.14 validity

That may be the fastest way to fix up the packages.  I would do this,
but you’re in a better position to judge whether the packages still do
what you intended them to do, since I imagine you have a use-case in
mind.  :)

Thanks!


-- Tim
Timothy Sample July 20, 2019, 3:16 a.m. UTC | #3
Hi Brian,

Brian Leung <bkleung89@gmail.com> writes:

> Hi Tim,
>
> OK, please see attached for the updated patches.

Pushed!

I had to make a few changes.  Mostly I shortened long lines, but there
were two larger changes:

  1. It looks like you forgot to downgrade “ghc-exactprint” to the LTS
     version (0.5.6.1).  Luckily, it was just a matter of changing the
     version and hash.

  2. There was something fishy about the synopsis and description of
     “ghc-microlens-ghc”.  It looks to me that they were in fact
     describing “ghc-microlens-platform”.  I ended up changing them a
     fair bit.

Thanks for the packages!


-- Tim
diff mbox series

Patch

From fbb2c48352235b8eb4ab1cb18349748f5a407ff5 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Fri, 21 Jun 2019 03:44:39 +0200
Subject: [PATCH 7/8] gnu: Add ghc-exactprint.

* gnu/packages/haskell.scm (ghc-exactprint): New variable.
---
 gnu/packages/haskell.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c80a8f43ad..c88b6e40f7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11730,6 +11730,39 @@  files/directories, and more.")
 and parsers with useful semantics.")
     (license license:bsd-3)))
 
+(define-public ghc-exactprint
+  (package
+    (name "ghc-exactprint")
+    (version "0.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/ghc-exactprint/ghc-exactprint-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "12nqpqmi9c57a3hgpfy8q073zryz66ylmcvf29hyffpj7vmmnvhl"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-paths" ,ghc-paths)
+       ("ghc-syb" ,ghc-syb)
+       ("ghc-free" ,ghc-free)))
+    (native-inputs
+     `(("ghc-hunit" ,ghc-hunit)
+       ("ghc-diff" ,ghc-diff)
+       ("ghc-silently" ,ghc-silently)
+       ("ghc-filemanip" ,ghc-filemanip)))
+    (home-page
+     "http://hackage.haskell.org/package/ghc-exactprint")
+    (synopsis "ExactPrint for GHC")
+    (description
+     "Using the API Annotations available from GHC 7.10.2, this library
+provides a means to round-trip any code that can be compiled by GHC, currently
+excluding @file{.lhs} files.")
+    (license license:bsd-3)))
+
 (define-public ghc-stylish-haskell
   (package
     (name "ghc-stylish-haskell")
-- 
2.22.0