[bug#35251] Add emacs packages

Message ID CAAc=MEzaKP=mn+v-GTP0LgTZTA3onKXFQnXQYsRKjgbzrOFjOg@mail.gmail.com
State Accepted
Headers show
Series [bug#35251] Add emacs packages | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung April 12, 2019, 11:20 p.m. UTC
See attached. I did remember to lint this time---the one complaint I
haven't resolved is that the linter recommends upgrading emacs-web-server
to "version-0.1.0", but in the source file the author lists the present
version as 0.1.1.

Comments

Ludovic Courtès April 14, 2019, 3:43 p.m. UTC | #1
Hi Brian,

I confirmed that all 32 packages build for me on x86_64 and pushed them.

Thank you!

Ludo’.

Patch

From 522a04abe575aa4fa671da358ab69628975592c7 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sat, 13 Apr 2019 01:12:50 +0200
Subject: [PATCH 32/32] gnu: Add emacs-eacl.

* gnu/packages/emacs-xyz.scm (emacs-eacl): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f6d9944a17..a1db2be856 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15078,6 +15078,29 @@  well as an option for visually flashing evaluated s-expressions.")
 SSH servers.")
     (license license:gpl3+)))
 
+(define-public emacs-eacl
+  (package
+    (name "emacs-eacl")
+    (version "2.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/redguardtoo/eacl")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ksn11sm3g1ja5lpjz3hrzzw8b480mfcb3q589m52qjgvvn5iyfv"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-ivy" ,emacs-ivy)))
+    (home-page "https://github.com/redguardtoo/eacl")
+    (synopsis "Auto-complete lines by using @code{grep} on a project")
+    (description "This package provides auto-completion cammands for single
+and multiple lines of code in a project.")
+    (license license:gpl3+)))
+
 (define-public emacs-semantic-refactor
   ;; The last release, 0.5, was made on 2015-07-26 and there have been 47
   ;; commits since then.
-- 
2.21.0