[bug#35023] Silence byte-compiler for emacs-zones.

Message ID CAAc=MEzZPUsvwEv_QXTWrQ3KQgw+RDW8=oLvOZ0TQ1rFExX88g@mail.gmail.com
State Accepted
Headers show
Series [bug#35023] Silence byte-compiler for emacs-zones. | expand

Commit Message

Brian Leung March 27, 2019, 8:44 p.m. UTC
See attached.

Comments

Ludovic Courtès March 31, 2019, 9:33 p.m. UTC | #1
Hi,

Brian Leung <bkleung89@gmail.com> skribis:

> From 3d80fb0c50ee6c5bcbfb93533575756ebf93cb7b Mon Sep 17 00:00:00 2001
> From: Brian Leung <bkleung89@gmail.com>
> Date: Wed, 27 Mar 2019 21:41:58 +0100
> Subject: [PATCH] gnu: emacs-zones: silence byte-compiler.
>
> * gnu/packages/patches/emacs-zones-called-interactively.patch: New file.

I added the patch to gnu/local.mk and committed, thanks!

Ludo’.

Patch

From 3d80fb0c50ee6c5bcbfb93533575756ebf93cb7b Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Wed, 27 Mar 2019 21:41:58 +0100
Subject: [PATCH] gnu: emacs-zones: silence byte-compiler.

* gnu/packages/patches/emacs-zones-called-interactively.patch: New file.
---
 gnu/packages/emacs-xyz.scm                    |  5 ++-
 .../emacs-zones-called-interactively.patch    | 43 +++++++++++++++++++
 2 files changed, 47 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/emacs-zones-called-interactively.patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7dd3c079b2..beb69858d4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5991,7 +5991,10 @@  customizable by the user.")
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "0gwnw2giii2a14nlh62xp45f47cw6ikqphhzpmcw6c7mn9x5z2ar"))))
+           "0gwnw2giii2a14nlh62xp45f47cw6ikqphhzpmcw6c7mn9x5z2ar"))
+         (patches
+          (search-patches
+           "emacs-zones-called-interactively.patch"))))
       (build-system emacs-build-system)
       (home-page "https://www.emacswiki.org/emacs/Zones")
       (synopsis "Define and act on multiple zones of buffer text")
diff --git a/gnu/packages/patches/emacs-zones-called-interactively.patch b/gnu/packages/patches/emacs-zones-called-interactively.patch
new file mode 100644
index 0000000000..b60f390a7e
--- /dev/null
+++ b/gnu/packages/patches/emacs-zones-called-interactively.patch
@@ -0,0 +1,43 @@ 
+From fb56fbb706804215ef9af0cc575db97c373046c6 Mon Sep 17 00:00:00 2001
+From: Brian Leung <bkleung89@gmail.com>
+Date: Sun, 17 Mar 2019 01:32:04 +0100
+Subject: [PATCH] This patch silences the byte-compiler.
+
+---
+ zones.el | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/zones.el b/zones.el
+index 1bf94f0..94fa9a6 100644
+--- a/zones.el
++++ b/zones.el
+@@ -1031,7 +1031,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+ 
+ This is a destructive operation. The list structure of the variable
+ value can be modified."
+-  (zz-narrow-advice (interactive-p)))
++  (zz-narrow-advice (called-interactively-p)))
+ 
+ (defadvice narrow-to-defun (after zz-add-zone--defun activate)
+   "Push the defun limits to the current `zz-izones-var'.
+@@ -1039,7 +1039,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+ 
+ This is a destructive operation. The list structure of the variable
+ value can be modified."
+-  (zz-narrow-advice (interactive-p)))
++  (zz-narrow-advice (called-interactively-p)))
+ 
+ ;; Call `zz-add-zone' if interactive or `zz-add-zone-anyway-p'.
+ ;;
+@@ -1049,7 +1049,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+ 
+ This is a destructive operation. The list structure of the variable
+ value can be modified."
+-  (zz-narrow-advice (interactive-p)))
++  (zz-narrow-advice (called-interactively-p)))
+ 
+ ;;(@* "General Commands")
+ 
+-- 
+2.21.0
+
-- 
2.21.0