[bug#34822] Add emacs-eshell-bookmark

Message ID CAAc=MEym5jk1URa_9Ye8_ZzG_RM32Hn3u-uySZDkGgaJHzBP1Q@mail.gmail.com
State Accepted
Headers show
Series [bug#34822] Add emacs-eshell-bookmark | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung March 12, 2019, 9 a.m. UTC
See attached.

Comments

Oleg Pykhalov March 12, 2019, 7:14 p.m. UTC | #1
Hello Brian,

Thank you for this package.  It's a handy library.

Pushed as 94a33ab899cddeda3b577cc968cd905623a692f1 to master.

Oleg.

Patch

From fc7bd51a09dd1dd3b67f55d4753e6cb37a9f9ce9 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 12 Mar 2019 09:45:00 +0100
Subject: [PATCH] gnu: Add emacs-eshell-bookmark.

---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 543cfaea3d..fd4c0bdf0f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11173,6 +11173,29 @@  systems.")
 filters, highlighting of regexp group levels, and more.")
       (license license:gpl2+))))
 
+(define-public emacs-eshell-bookmark
+  (package
+    (name "emacs-eshell-bookmark")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Fuco1/eshell-bookmark")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "14dmsnixf9vqdhsixw693sml0fn80zcf0b37z049fb40cmppqxdw"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/Fuco1/eshell-bookmark")
+    (synopsis "Provide @file{bookmark.el} integration for @code{eshell}")
+    (description
+     "This package allows for bookmarking @code{eshell} buffers.  Upon
+visiting the bookmark, a new @code{eshell} session will be opened in the
+appropriate directory if no @code{eshell} session is active.")
+    (license license:gpl3+)))
+
 (define-public emacs-esh-autosuggest
   (package
     (name "emacs-esh-autosuggest")
-- 
2.21.0