diff mbox series

[bug#36413] Add and update Emacs packages.

Message ID CAAc=MEyT_C-FROHQ182Sephi9o3T8NFPuHed4Djk0wD72d3S_w@mail.gmail.com
State Accepted
Headers show
Series [bug#36413] Add and update Emacs packages. | expand

Commit Message

Brian Leung July 5, 2019, 4:44 a.m. UTC
I've rebased and added several more patches.

On Fri, Jun 28, 2019 at 4:58 AM Brian Leung <bkleung89@gmail.com> wrote:

> See attached.
>
diff mbox series

Patch

From cb686da2c0dfc5217fe7cfba7af7c978ba1631d7 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Fri, 5 Jul 2019 06:37:39 +0200
Subject: [PATCH 12/12] gnu: emacs-goto-chg: Update to 1.7.3.

* gnu/packages/emacs-xyz.scm (emacs-goto-chg): Update to 1.7.3.
[origin]: Use GIT-FETCH and GIT-REFERENCE.
[home-page]: Update.
[inputs]: Add emacs-undo-tree.
---
 gnu/packages/emacs-xyz.scm | 43 +++++++++++++++++++++-----------------
 1 file changed, 24 insertions(+), 19 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2cb9a7dc92..0c562b8675 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6136,28 +6136,33 @@  Emacs that Evil does not cover properly by default, such as @code{help-mode},
       (license license:gpl3+))))
 
 (define-public emacs-goto-chg
-  (package
-    (name "emacs-goto-chg")
-    (version "1.6")
-    (source
-     (origin
-       (method url-fetch)
-       ;; There is no versioned source.
-       (uri "https://www.emacswiki.org/emacs/download/goto-chg.el")
-       (file-name (string-append "goto-chg-" version ".el"))
-       (sha256
-        (base32
-         "078d6p4br5vips7b9x4v6cy0wxf6m5ij9gpqd4g33bryn22gnpij"))))
-    (build-system emacs-build-system)
-    ;; There is no other home page.
-    (home-page "https://www.emacswiki.org/emacs/goto-chg.el")
-    (synopsis "Go to the last change in the Emacs buffer")
-    (description
-     "This package provides @code{M-x goto-last-change} command that goes to
+  (let ((commit "1829a13026c597e358f716d2c7793202458120b5")
+        (version "1.7.3")
+        (revision "1"))
+    (package
+      (name "emacs-goto-chg")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacs-evil/goto-chg")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1y603maw9xwdj3qiarmf1bp13461f9f5ackzicsbynl0i9la3qki"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-undo-tree" ,emacs-undo-tree)))
+      (home-page "https://github.com/emacs-evil/goto-chg")
+      (synopsis "Go to the last change in the Emacs buffer")
+      (description
+       "This package provides @code{M-x goto-last-change} command that goes to
 the point of the most recent edit in the current Emacs buffer.  When repeated,
 go to the second most recent edit, etc.  Negative argument, @kbd{C-u -}, is
 used for reverse direction.")
-    (license license:gpl2+)))
+      (license license:gpl2+))))
 
 (define-public emacs-janpath-evil-numbers
   (let ((commit "d988041c1fe6e941dc8d591390750b237f71f524")
-- 
2.22.0