diff mbox series

[bug#36778] Add and update Emacs packages.

Message ID CAAc=MEyLKxru4sMTntrN+AGpo_wqzLYZ0YxM3=WJi5WUBzT=DQ@mail.gmail.com
State Accepted
Headers show
Series [bug#36778] Add and update Emacs packages. | expand

Commit Message

Brian Leung July 30, 2019, 9:03 a.m. UTC
I've rebased and updated with several more patches.

On Sat, Jul 27, 2019 at 5:23 AM Brian Leung <bkleung89@gmail.com> wrote:

> I rebased and added a few additional patches.
>
diff mbox series

Patch

From a6832ea59a06235b8814a94d915e955acda45f6a Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 30 Jul 2019 10:59:10 +0200
Subject: [PATCH 16/16] gnu: Add emacs-company-math.

* gnu/packages/emacs-xyz.scm (emacs-company-math): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e7ab2cc21c..178fd6e403 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3412,6 +3412,32 @@  completion candidate when using the Company text completion framework.")
 @code{company-math}.")
       (license license:gpl3+))))
 
+(define-public emacs-company-math
+  (let ((commit "600e49449644f6835f9dc3501bc58461999e8ab9")
+        (version "1.3")
+        (revision "1"))
+    (package
+      (name "emacs-company-math")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/vspinu/company-math.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1ps2lpkzn8mjbpcbvvy1qz3xbgrh6951x8y9bsd1fm32drdph9lh"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-math-symbol-lists" ,emacs-math-symbol-lists)
+         ("emacs-company" ,emacs-company)))
+      (home-page "https://github.com/vspinu/company-math")
+      (synopsis "Completion backends for Unicode math symbols and @code{LaTeX} tags")
+      (description "This package provides a backend for use with
+@code{company-mode} allowing for completion of common math symbols.")
+      (license license:gpl3+))))
+
 (define-public emacs-multiple-cursors
   (package
     (name "emacs-multiple-cursors")
-- 
2.22.0