diff mbox series

[bug#36999] gnu: Add emacs-forge.

Message ID CAAc=MEyGTJ5rc1v_0rTXacx6ViXk6RUy-qVgwmj6b_pLarj8ng@mail.gmail.com
State Accepted
Headers show
Series [bug#36999] gnu: Add emacs-forge. | expand

Commit Message

Brian Leung Aug. 14, 2019, 6:08 a.m. UTC
Hi Oleg,

I've made a patch off the latest master branch with a version of emacs-ghub
that should meet the requirements of emacs-forge.

Best,
Brian

On Sun, Aug 11, 2019 at 7:39 PM Brian Leung <bkleung89@gmail.com> wrote:

> Hi Oleg,
>
> I notice that emacs-forge, in its forge-pkg.el file, mentions newer
> dependencies than what we currently have: ghub version 20190319, which
> apparently contains a fix for a relevant bug; and Magit version 20190408.
> I'm not sure how important the update to Magit is, and this newer version
> of Magit also happens to depend on an additional package, libegit2. It
> might be nice to update our version of ghub.
>
> Best,
> Brian
>

Comments

Oleg Pykhalov Aug. 18, 2019, 9:26 a.m. UTC | #1
Hi Brian,

Apologies for a delay with response.

Brian Leung <bkleung89@gmail.com> writes:

> Hi Oleg,
>
> I've made a patch off the latest master branch with a version of emacs-ghub
> that should meet the requirements of emacs-forge.

Thank you!

[…]

>> I notice that emacs-forge, in its forge-pkg.el file, mentions newer
>> dependencies than what we currently have: ghub version 20190319, which
>> apparently contains a fix for a relevant bug; and Magit version 20190408.
>> I'm not sure how important the update to Magit is, and this newer version
>> of Magit also happens to depend on an additional package, libegit2. It
>> might be nice to update our version of ghub.

Unfortunately Magit update is needed, because on a GitLab instance you
could list issues but not open them to take a look on a content.

New Magit requires https://github.com/magit/libegit2 which I try to
build, but stuck.  I succeeded to build ‘libgit2.so’ and load it in
Emacs, but ‘featurep’ procedure says that feature is not loaded.

I think we should not merge partially working emacs-forge.

Regards,
Oleg.
Kyle Meyer Aug. 18, 2019, 2:07 p.m. UTC | #2
Hi Oleg,

Oleg Pyhalov <go.wigust@gmail.com> writes:

[...]

> New Magit requires https://github.com/magit/libegit2 which I try to
> build, but stuck.  I succeeded to build ‘libgit2.so’ and load it in
> Emacs, but ‘featurep’ procedure says that feature is not loaded.

I haven't been following this thread closely, but in case it's useful:
Building Magit should work without libegit2 if you set
BUILD_MAGIT_LIBGIT to false.
diff mbox series

Patch

From 8f7c7623743cf2b0bc06b9ae34bac7ac2b1e7994 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Wed, 14 Aug 2019 08:04:20 +0200
Subject: [PATCH] gnu: emacs-ghub: Update to 3.2.0-1.7d59937.

* gnu/packages/emacs-xyz.scm (emacs-ghub): Update to 3.2.0-1.7d59937.
---
 gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++++------------------
 1 file changed, 32 insertions(+), 30 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6e612cab56..23e5e09d2a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -521,39 +521,41 @@  deliver data to mobile and web apps.")
    (license license:gpl3+)))
 
 (define-public emacs-ghub
-  (package
-    (name "emacs-ghub")
-    (version "3.2.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/magit/ghub")
-                     (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0lp52qygyavddl1lrgsyb6mq7hcf9h89dy2pzya3mb2va49f0vvl"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'make-info
-           (lambda _
-             (invoke "make" "info"))))))
-    (native-inputs
-     `(("texinfo" ,texinfo)))
-    (propagated-inputs
-     `(("dash" ,emacs-dash)
-       ("graphql" ,emacs-graphql)
-       ("treepy" ,emacs-treepy)))
-    (home-page "https://github.com/magit/ghub")
-    (synopsis "Emacs client libraries for the APIs of various Git forges")
-    (description
-     "Ghub provides basic support for using the APIs of various Git forges from
+  ;; We need a newer commit to avoid problems in emacs-forge.
+  (let ((commit "7d59937d7782d0062216130a4d059b45e8396f82")
+        (revision "1"))
+    (package
+      (name "emacs-ghub")
+      (version (git-version "3.2.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/magit/ghub")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1ngb61nij9gznqplwg1fmr1vq1czry759hmdibzngl4wqhxpfsjq"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-before 'install 'make-info
+             (lambda _
+               (invoke "make" "info"))))))
+      (native-inputs
+       `(("texinfo" ,texinfo)))
+      (propagated-inputs
+       `(("dash" ,emacs-dash)
+         ("treepy" ,emacs-treepy)))
+      (home-page "https://github.com/magit/ghub")
+      (synopsis "Emacs client libraries for the APIs of various Git forges")
+      (description
+       "Ghub provides basic support for using the APIs of various Git forges from
 Emacs packages.  It supports the REST APIs of Github, Github GraphQL, Gitlab,
 Gitea, Gogs and Bitbucket.  It abstracts access to API resources using only a
 handful of functions that are not resource-specific.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-scribble-mode
   (let ((commit "34e9e5edb921813b6483e0fefa848efb6ee4b314")
-- 
2.22.0