diff mbox series

[bug#38487] Add ghc-apply-refact

Message ID CAAc=MExdk_bO08e8BZZ3-O=GH_2S7xV=i0xq7T_=pEDfKvHB3A@mail.gmail.com
State Accepted
Headers show
Series [bug#38487] Add ghc-apply-refact | expand

Commit Message

Brian Leung Dec. 4, 2019, 7:04 a.m. UTC
See attached.

Comments

John Soo Jan. 17, 2020, 4:33 p.m. UTC | #1
Hi Brian,

Thanks for another haskell tool! I built it this morning and it built.
I do not use apply-refact, though. Have you been using it with
success?

My only thought is to move this package to haskell-apps.scm and call
the package apply-refact. What do you think?

John
diff mbox series

Patch

From e2df81c5a5e8692e3f981ec9bf5c28cf65cfa124 Mon Sep 17 00:00:00 2001
From: Brian Leung <brian@debian>
Date: Tue, 3 Dec 2019 23:03:06 -0800
Subject: [PATCH] gnu: Add ghc-apply-refact.

* gnu/packages/haskell-xyz.scm (ghc-apply-refact): New variable.
---
 gnu/packages/haskell-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fb6833207d..57a64fa880 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13148,3 +13148,41 @@  Zstandard compression algorithm, a fast lossless compression algorithm
 targeting real-time compression scenarios at zlib-level and better
 compression ratios.")
     (license license:bsd-3)))
+
+(define-public ghc-apply-refact
+  (package
+    (name "ghc-apply-refact")
+    (version "0.6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/apply-refact/apply-refact-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0p2mqgjcqr1zcmk8zgr0yq7g8z1agsa6l493lkj6g3ya9lyhxgig"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-refact" ,ghc-refact)
+       ("ghc-exactprint" ,ghc-exactprint)
+       ("ghc-syb" ,ghc-syb)
+       ("ghc-temporary" ,ghc-temporary)
+       ("ghc-filemanip" ,ghc-filemanip)
+       ("ghc-unix-compat" ,ghc-unix-compat)
+       ("ghc-optparse-applicative"
+        ,ghc-optparse-applicative)))
+    (native-inputs
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-golden" ,ghc-tasty-golden)
+       ("ghc-tasty-expected-failure"
+        ,ghc-tasty-expected-failure)
+       ("ghc-silently" ,ghc-silently)))
+    (home-page
+     "http://hackage.haskell.org/package/apply-refact")
+    (synopsis
+     "Perform refactorings specified by the refact library.")
+    (description
+     "Perform refactorings specified by the refact library. It is primarily used with HLint's --refactor flag.")
+    (license license:bsd-3)))
-- 
2.24.0