From e2df81c5a5e8692e3f981ec9bf5c28cf65cfa124 Mon Sep 17 00:00:00 2001
From: Brian Leung <brian@debian>
Date: Tue, 3 Dec 2019 23:03:06 -0800
Subject: [PATCH] gnu: Add ghc-apply-refact.
* gnu/packages/haskell-xyz.scm (ghc-apply-refact): New variable.
---
gnu/packages/haskell-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)
@@ -13148,3 +13148,41 @@ Zstandard compression algorithm, a fast lossless compression algorithm
targeting real-time compression scenarios at zlib-level and better
compression ratios.")
(license license:bsd-3)))
+
+(define-public ghc-apply-refact
+ (package
+ (name "ghc-apply-refact")
+ (version "0.6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/apply-refact/apply-refact-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0p2mqgjcqr1zcmk8zgr0yq7g8z1agsa6l493lkj6g3ya9lyhxgig"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-refact" ,ghc-refact)
+ ("ghc-exactprint" ,ghc-exactprint)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-temporary" ,ghc-temporary)
+ ("ghc-filemanip" ,ghc-filemanip)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-optparse-applicative"
+ ,ghc-optparse-applicative)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-expected-failure"
+ ,ghc-tasty-expected-failure)
+ ("ghc-silently" ,ghc-silently)))
+ (home-page
+ "http://hackage.haskell.org/package/apply-refact")
+ (synopsis
+ "Perform refactorings specified by the refact library.")
+ (description
+ "Perform refactorings specified by the refact library. It is primarily used with HLint's --refactor flag.")
+ (license license:bsd-3)))
--
2.24.0