diff mbox series

[bug#35467] Update Emacs packages.

Message ID CAAc=MExWvqT7VHcEf6J4o=f8uqkB0DKs0iKV8zthvhM4z=dN+g@mail.gmail.com
State Accepted
Headers show
Series [bug#35467] Update Emacs packages. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung May 25, 2019, 4:50 a.m. UTC
I've added an update to emacs-lispy as well.

On Mon, May 20, 2019 at 5:28 PM Brian Leung <bkleung89@gmail.com> wrote:

> Friendly ping.
>
> On Tue, May 14, 2019 at 1:36 AM Brian Leung <bkleung89@gmail.com> wrote:
>
>> Hi Ricardo,
>>
>> OK, it looks like emacs-avy received a version bump two days ago. I've
>> modified the patches appropriately and rebased with Guix's latest master
>> branch.
>>
>> Best,
>> Brian
>>
>> On Mon, May 6, 2019 at 8:25 PM Brian Leung <bkleung89@gmail.com> wrote:
>>
>>> Hi Ricardo,
>>>
>>> OK, I've made your suggested changes.
>>>
>>> For future reference, is it possible to edit a past commit message with
>>> git fixup? I know how to edit the actual contents of past commits using git
>>> fixup, but not their commit messages. For these two patches, I had to
>>> manually make new commits.
>>>
>>> Best,
>>> Brian
>>>
>>> On Mon, May 6, 2019 at 7:02 PM Ricardo Wurmus <rekado@elephly.net>
>>> wrote:
>>>
>>>>
>>>> Hi Brian,
>>>>
>>>> > Thanks for your response. The release version of
>>>> emacs-highlight-symbol
>>>> > prints an occurrence count in the echo area upon hovering over a
>>>> symbol,
>>>> > which is annoying because it can drown out important messages from
>>>> (say)
>>>> > eldoc; this PR <https://github.com/nschum/highlight-symbol.el/pull/31
>>>> >,
>>>> > which is not included in the release version, fixes that. The last
>>>> release
>>>> > version of emacs-avy was from January 2016, and there have since been
>>>> > slightly over 100 commits since then for various features and bug
>>>> > fixes.
>>>>
>>>> I see.  It would be good to include this information as a comment so
>>>> that people looking at this in the future understand why it was done.
>>>>
>>>> Please also change the commit message to state the actual version and
>>>> not just a prefix of the commit hash.  Please use the version string
>>>> that would be used by Guix (something like “1.2.3-1.cabbage”).
>>>>
>>>> --
>>>> Ricardo
>>>>
>>>>

Comments

Ricardo Wurmus May 25, 2019, 10:06 a.m. UTC | #1
Hi Brian,

> I've added an update to emacs-lispy as well.

Thanks, I’ve pushed them with commit 7547648.

Note: there was a mistake in the version string for
emacs-highlight-symbol in the commit message, which I overlooked.  It
should have been 1.3-1.7a789c7, not 1.3.1-7a789c7.

--
Ricardo
diff mbox series

Patch

From 9c18d3d42a3754f440f593edc4fdfbb8606f263f Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 14 May 2019 00:12:49 +0200
Subject: [PATCH 1/3] gnu: emacs-highlight-symbol: Update to 1.3.1-7a789c7.

* gnu/packages/emacs-xyz.scm (emacs-highlight-symbol): Update to 1.3.1-7a789c7.
---
 gnu/packages/emacs-xyz.scm | 42 ++++++++++++++++++++++----------------
 1 file changed, 24 insertions(+), 18 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index beb35c8122..b686582d62 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4074,23 +4074,29 @@  well as completely new features.")
     (license license:gpl3+)))
 
 (define-public emacs-highlight-symbol
-  (package
-    (name "emacs-highlight-symbol")
-    (version "1.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/nschum/highlight-symbol.el.git")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "09z13kv2g21kjjkkm3iyaz93sdjmdy2d563r8n7r7ng94acrn7f6"))))
-    (build-system emacs-build-system)
-    (home-page "https://nschum.de/src/emacs/highlight-symbol")
-    (synopsis "Automatic and manual symbol highlighting for Emacs")
-    (description
-     "Use @code{highlight-symbol} to toggle highlighting of the symbol at
+  ;; We prefer a more recent commit that provides an option to squelch
+  ;; echo-area alerts that can drown out useful information like eldoc
+  ;; messages.
+  (let ((commit "7a789c779648c55b16e43278e51be5898c121b3a")
+        (version "1.3")
+        (revision "1"))
+    (package
+      (name "emacs-highlight-symbol")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/nschum/highlight-symbol.el.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "19cgyk0sh8nsmf3jbi92i8qsdx4l4yilfq5jj9zfdbj9p5gvwx96"))))
+      (build-system emacs-build-system)
+      (home-page "https://nschum.de/src/emacs/highlight-symbol/")
+      (synopsis "Automatic and manual symbol highlighting for Emacs")
+      (description
+       "Use @code{highlight-symbol} to toggle highlighting of the symbol at
 point throughout the current buffer.  Use @code{highlight-symbol-mode} to keep
 the symbol at point highlighted.
 
@@ -4103,7 +4109,7 @@  bindings @code{M-p} and @code{M-p} for navigation.  When
 regardless of @code{highlight-symbol-idle-delay}.
 
 @code{highlight-symbol-query-replace} can be used to replace the symbol. ")
-    (license license:gpl2+)))
+      (license license:gpl2+))))
 
 (define-public emacs-hl-todo
   (package
-- 
2.21.0