diff mbox series

[bug#37061] Add emacs-org packages.

Message ID CAAc=MExRjyFURj3Uw2fKfZruqRiVXRSTtHeEu-yU10CzFKnibg@mail.gmail.com
State Accepted
Headers show
Series [bug#37061] Add emacs-org packages. | expand

Commit Message

Brian Leung Aug. 17, 2019, 5:01 a.m. UTC
See attached.
diff mbox series

Patch

From 41f2be66533eabc0c9925ca5eae74c2b9c43ef52 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sat, 17 Aug 2019 06:59:48 +0200
Subject: [PATCH 3/3] gnu: Add emacs-org-now.

* gnu/packages/emacs-xyz.scm (emacs-org-now): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9512a2494a..00da280f0d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2776,6 +2776,33 @@  been copied from an Emacs major mode.")
        "This package integrates @code{restclient-mode} with Org.")
       (license license:gpl3+))))
 
+(define-public emacs-org-now
+  (let ((commit "8f6b277a73f1c66e58ccb4b7f40d406851befc91")
+        (revision "1"))
+    (package
+      (name "emacs-org-now")
+      (version "0.1-pre")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/alphapapa/org-now.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "117zzkryznznk6h4i1jqzdn888nl019xrgxm2gza0lndx8dxsg2c"))))
+      (propagated-inputs
+       `(("emacs-dash" ,emacs-dash)))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/alphapapa/org-now")
+      (synopsis "Show current Org tasks in a sidebar")
+      (description
+       "This package provides commands to show Org headings in a sidebar
+window while working on them. After defining one heading as the \"now\"
+heading, other headings can be refiled to it with one command, and back to
+their original location with another.")
+      (license license:gpl3+))))
+
 (define-public emacs-rich-minority
   (package
     (name "emacs-rich-minority")
-- 
2.22.0