diff mbox series

[bug#36778] Add and update Emacs packages.

Message ID CAAc=MExHwTNgL=N-wbDKrhexBLu5un+KFZf=Ceqtc6P-j8be5w@mail.gmail.com
State Accepted
Headers show
Series [bug#36778] Add and update Emacs packages. | expand

Commit Message

Brian Leung Aug. 2, 2019, 4:45 a.m. UTC
OK, I've added two more patches.

On Thu, Aug 1, 2019 at 6:02 PM Brian Leung <bkleung89@gmail.com> wrote:

> I've added another patch.
>
> On Tue, Jul 30, 2019 at 11:03 AM Brian Leung <bkleung89@gmail.com> wrote:
>
>> I've rebased and updated with several more patches.
>>
>> On Sat, Jul 27, 2019 at 5:23 AM Brian Leung <bkleung89@gmail.com> wrote:
>>
>>> I rebased and added a few additional patches.
>>>
>>
diff mbox series

Patch

From d44629e12e479aa7777ca24ef63fe416f17f9a06 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Fri, 2 Aug 2019 06:43:00 +0200
Subject: [PATCH 2/2] gnu: Add emacs-org-sidebar.

* gnu/packages/emacs-xyz.scm (emacs-org-sidebar): New variable.
---
 gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 254b387797..60308fd1a6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4110,6 +4110,39 @@  minutes is started automatically.  Every 4 breaks a long break is
 started with 20 minutes.  All values are customizable.")
     (license license:gpl3+)))
 
+(define-public emacs-org-sidebar
+  (let ((commit "74ca98b9920f3de3f13d49866581435e1ec63ec5")
+        (version "0.1")
+        (revision "1"))
+    (package
+      (name "emacs-org-sidebar")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/alphapapa/org-sidebar.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "03p1ndyw2qp2skib5hszc4xyh84w7p2mhkd4a9dy6qv8q47xpsqn"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-dash" ,emacs-dash)
+         ("emacs-org-super-agenda" ,emacs-org-super-agenda)
+         ("emacs-org" ,emacs-org)
+         ("emacs-org-ql" ,emacs-org-ql)
+         ("emacs-s" ,emacs-s)))
+      (home-page "https://github.com/alphapapa/org-sidebar")
+      (synopsis "Helpful sidebar for Org buffers")
+      (description "This package provides a sidebar for Org buffers.  At the
+top is a chronological list of scheduled and deadlined tasks in the current
+buffer (similar to the Org agenda ,but without all its features), and below
+that is a list of all other non-done to-do items.  If the buffer is narrowed,
+the sidebar only shows items in the narrowed portion; this allows seeing an
+overview of tasks in a subtree.")
+      (license license:gpl3+))))
+
 (define-public emacs-org-trello
   (package
     (name "emacs-org-trello")
-- 
2.22.0