diff mbox series

[bug#37204] Add emacs-helm-ag.

Message ID CAAc=MEx=4WRQvzkFnNRGNV4E4ye=qnkvfcX2fNdOocOVu5wFgw@mail.gmail.com
State Accepted
Headers show
Series [bug#37204] Add emacs-helm-ag. | expand

Commit Message

Brian Leung Aug. 28, 2019, 6:32 a.m. UTC
See attached.

Comments

Oleg Pykhalov Aug. 30, 2019, 9:11 a.m. UTC | #1
Hello Brian,

Thanks.  Pushed to master.

Oleg.
diff mbox series

Patch

From 44924f89bcf62d3d4eccfab1ba4a78774a5b9e86 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Wed, 28 Aug 2019 08:31:35 +0200
Subject: [PATCH] gnu: Add emacs-helm-ag.

* gnu/packages/emacs-xyz.scm (emacs-helm-ag): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5d667a7aa..a5a249d29a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6295,6 +6295,31 @@  not tied in the trap of backward compatibility.")
 for search-based navigation of buffers.")
     (license license:gpl2+)))
 
+(define-public emacs-helm-ag
+  (let ((commit "2fc02c4ead29bf0db06fd70740cc7c364cb650ac")
+        (revision "1"))
+    (package
+      (name "emacs-helm-ag")
+      (version "0.58")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/syohex/emacs-helm-ag.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1gnn0byywbld6afcq1vp92cjvy4wlag9d1wgymnqn86c3b1bcf21"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-helm" ,emacs-helm)))
+      (home-page "https://github.com/syohex/emacs-helm-ag")
+      (synopsis "Helm interface to the Silver Searcher")
+      (description
+       "This package provides a frontend for grepping tools like ag and ack,
+as well as features for editing search results.")
+      (license license:gpl3+))))
+
 (define-public emacs-helm-projectile
   (package
     (name "emacs-helm-projectile")
-- 
2.23.0