[bug#34521] Guix patch

Message ID CAAc=MEx9FbHCZSdeUpnzqtDq6J+r5g2TeJ2VQC4SASLXt7jraQ@mail.gmail.com
State Accepted
Headers show
Series [bug#34521] Guix patch | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung Feb. 18, 2019, 2:50 a.m. UTC
See attached.

Comments

Ricardo Wurmus Feb. 18, 2019, 3:36 p.m. UTC | #1
Hi Brian,

> Subject: [PATCH] gnu: Add emacs-isearch-prop.

Thank you for the patch.

> +(define-public emacs-isearch-prop
> +  (let ((commit "5e9dc44cf582d998aaa73ccd4d07cbda01248156")
> +        (revision "1"))
> +    (package
> +      (name "emacs-isearch-prop")
> +      (version (git-version "0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/emacsmirror/isearch-prop.git")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> +           "1xawppy705ybsgx566zvj8zk2aajq0sqvhvfs7nijqq32lx0a2zl"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://www.emacswiki.org/emacs/isearch-prop.el")
> +      (synopsis "Extensions to `isearch.el'")
> +      (description "Search text- or overlay-property contexts.")

This description is a bit short.  How about this:

  The Emacs library @code{isearch-prop.el} lets you search within
  contexts.  You can limit incremental search to a set of zones of
  buffer text, search contexts that in effect constitute a multi-region.
  These zones can be defined in various ways, including some ways
  provided specially by this library.

What do you think?

> +      (license license:gpl2+))))

The license is actually GPLv3+.

--
Ricardo
Ricardo Wurmus Feb. 18, 2019, 9:09 p.m. UTC | #2
Hi Brian,

> Please ignore my last email---here is another fix to the patch.

Thank you.  I pushed it to the master branch with commit 48211de6d.

Patch

From 869067c023cc1937e6f1f2656aa41b799ffdf34f Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Mon, 18 Feb 2019 03:32:08 +0100
Subject: [PATCH] gnu: Add emacs-isearch-prop.
To: guix-patches@gnu.org

From: leungbk <bkleung89@gmail.com>

---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bd3c51b087..d06b14ea34 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9626,6 +9626,28 @@  until the top-level form is no longer a macro call.")
     (description "Execute menu items as commands, with completion.")
     (license license:gpl3)))
 
+(define-public emacs-isearch-prop
+  (let ((commit "5e9dc44cf582d998aaa73ccd4d07cbda01248156")
+        (revision "1"))
+    (package
+      (name "emacs-isearch-prop")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsmirror/isearch-prop.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1xawppy705ybsgx566zvj8zk2aajq0sqvhvfs7nijqq32lx0a2zl"))))
+      (build-system emacs-build-system)
+      (home-page "https://www.emacswiki.org/emacs/isearch-prop.el")
+      (synopsis "Extensions to `isearch.el'")
+      (description "Search text- or overlay-property contexts.")
+      (license license:gpl2+))))
+
 (define-public emacs-company-lua
   (let ((commit "0be8122f3adf57ad27953bf4b03545d6298d3da4"))
     (package
-- 
2.20.1