diff mbox series

[bug#36326] Add Haskell packages.

Message ID CAAc=MEwOWinJPzp6ZhKkspu63-KAJZhs393PnCJ5sxUq+FM9+A@mail.gmail.com
State Accepted
Headers show
Series [bug#36326] Add Haskell packages. | expand

Commit Message

Brian Leung June 21, 2019, 6:51 p.m. UTC
See attached.
diff mbox series

Patch

From f558446a905079ced1fae0b8755ae0caf17fb383 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Fri, 21 Jun 2019 03:44:39 +0200
Subject: [PATCH 7/7] gnu: Add ghc-exactprint.

* gnu/packages/haskell.scm (ghc-exactprint): New variable.
---
 gnu/packages/haskell.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9c1a31af16..3730d89946 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11728,6 +11728,39 @@  files/directories, and more.")
 and parsers with useful semantics.")
     (license license:bsd-3)))
 
+(define-public ghc-exactprint
+  (package
+    (name "ghc-exactprint")
+    (version "0.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/ghc-exactprint/ghc-exactprint-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "12nqpqmi9c57a3hgpfy8q073zryz66ylmcvf29hyffpj7vmmnvhl"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-paths" ,ghc-paths)
+       ("ghc-syb" ,ghc-syb)
+       ("ghc-free" ,ghc-free)))
+    (native-inputs
+     `(("ghc-hunit" ,ghc-hunit)
+       ("ghc-diff" ,ghc-diff)
+       ("ghc-silently" ,ghc-silently)
+       ("ghc-filemanip" ,ghc-filemanip)))
+    (home-page
+     "http://hackage.haskell.org/package/ghc-exactprint")
+    (synopsis "ExactPrint for GHC")
+    (description
+     "Using the API Annotations available from GHC 7.10.2, this library
+provides a means to round-trip any code that can be compiled by GHC, currently
+excluding @file{.lhs} files.")
+    (license license:bsd-3)))
+
 (define-public ghc-stylish-haskell
   (package
     (name "ghc-stylish-haskell")
-- 
2.22.0