[bug#34724] Guix patch: emacs-debpaste

Message ID CAAc=MEw=9pW0TS=qKFTzYQbd7B4f8-1b5t6gRGtTPDokN-j_MQ@mail.gmail.com
State Accepted
Headers show
Series [bug#34724] Guix patch: emacs-debpaste | expand

Checks

Context Check Description
cbaines/comparison success View comparison
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung March 4, 2019, 12:46 a.m. UTC
See attached.

Comments

Brian Leung March 4, 2019, 2:24 a.m. UTC | #1
For the emacs-xml-rpc package, I elected not to use the Release versions
since they don't work properly with Emacs 25 and up.

Patch

From f789513e7f359540725f93d601d9f17b04eb3243 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Mon, 4 Mar 2019 01:39:57 +0100
Subject: [PATCH 2/3] gnu: Add emacs-xml-rpc.
To: guix-patches@gnu.org

---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dda5500f9d..b1a0d99efb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11358,6 +11358,33 @@  Org-mode.  It features:
 @end itemize\n")
       (license license:gpl3+))))
 
+(define-public emacs-xml-rpc
+  (let ((commit "8f624f8b964e9145acb504e4457c9510e87dd93c")
+        (revision "1"))
+    (package
+      (name "emacs-xml-rpc")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/hexmode/xml-rpc-el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0xa54z52rsfl3n0xgmbycj4zazp8ksgdwcq56swzs6wp72zlalmj"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/hexmode/xml-rpc-el")
+      (synopsis "This is an XML-RPC client implementation in Elisp,
+capable of both synchronous and asynchronous method calls using the url
+package's async retrieval functionality.")
+      (description "@file{xml-rpc.el} represents XML-RPC datatypes as Lisp values,
+automatically converting to and from the XML datastructures as needed, both
+for method parameters and return values, making using XML-RPC methods fairly
+transparent to the Lisp code.")
+      (license license:gpl3+))))
+
 (define-public emacs-fish-completion
   (package
     (name "emacs-fish-completion")
-- 
2.21.0