diff mbox series

[bug#36218] Add and update Emacs packages.

Message ID CAAc=MEw1=Dt+9WOyxKza83f1LgETYo0ChAr095_oEiVs4O9URw@mail.gmail.com
State Accepted
Headers show
Series [bug#36218] Add and update Emacs packages. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung June 15, 2019, 2:39 a.m. UTC
See attached.
diff mbox series

Patch

From 635dddf93c4c98e8746fda172ae969c41d014b0f Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sat, 15 Jun 2019 04:36:19 +0200
Subject: [PATCH 20/22] gnu: Add emacs-org-super-agenda.

* gnu/packages/emacs-xyz.scm (emacs-org-super-agenda): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 36562bd4a1..ecb173464b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10118,6 +10118,31 @@  heuristic based on freqency and recency.")
 as well as functions for navigating between these headings.")
     (license license:gpl3+)))
 
+(define-public emacs-org-super-agenda
+  (package
+   (name "emacs-org-super-agenda")
+   (version "1.1")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/alphapapa/org-super-agenda")
+                  (commit version)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "0vzf91lsxnhwf52kvm8ycpf0wb9c8l91689vyhwgv4wz8q6cvjwp"))))
+   (build-system emacs-build-system)
+   (propagated-inputs
+    `(("emacs-org" ,emacs-org)
+      ("emacs-dash" ,emacs-dash)
+      ("emacs-ht" ,emacs-ht)
+      ("emacs-s" ,emacs-s)))
+   (home-page "https://github.com/alphapapa/org-super-agenda")
+   (synopsis "Supercharged Org agenda")
+   (description "This package allows items in the Org agenda to be grouped
+into sections while preserving the structure imposed by any timestamps.")
+   (license license:gpl3+)))
+
 (define-public emacs-parsebib
   (package
     (name "emacs-parsebib")
-- 
2.22.0