diff mbox series

[bug#38487] gnu: Add ghc-apply-refact.

Message ID CAAc=MEw-hByymoAYtyvYmkENKD9Z3--z_tkQbPd+YmRBfmXovg@mail.gmail.com
State Accepted
Headers show
Series [bug#38487] gnu: Add ghc-apply-refact. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Brian Leung Jan. 24, 2020, 4:45 a.m. UTC
Hi John,

Thanks for your reply. I tested it just now and it seems to work. I've made
your suggested changes and also attached a related patch.

Best,
Brian

On Fri, Jan 17, 2020 at 8:33 AM John Soo <jsoo1@asu.edu> wrote:

> Hi Brian,
>
> Thanks for another haskell tool! I built it this morning and it built.
> I do not use apply-refact, though. Have you been using it with
> success?
>
> My only thought is to move this package to haskell-apps.scm and call
> the package apply-refact. What do you think?
>
> John
>

Comments

Marius Bakke March 29, 2020, 7:05 p.m. UTC | #1
Brian Leung <bkleung89@gmail.com> writes:

> Hi John,
>
> Thanks for your reply. I tested it just now and it seems to work. I've made
> your suggested changes and also attached a related patch.

Thanks!  I added copyright information for you, fixed some issues
reported by 'guix lint' as well as unnecessary linebreaks, and applied
both patches.
diff mbox series

Patch

From 8eb239e18e98848ddbc20d6dc0677b270547c147 Mon Sep 17 00:00:00 2001
From: Brian Leung <leungbk@mailfence.com>
Date: Thu, 23 Jan 2020 20:36:20 -0800
Subject: [PATCH 2/2] gnu: Add emacs-hlint-refactor-mode.

* gnu/packages/emacs-xyz.scm (emacs-hlint-refactor-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 40839d4869..f119cf690b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -101,6 +101,7 @@ 
   #:use-module (gnu packages guile)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages haskell-apps)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -15986,6 +15987,32 @@  text in neighboring sections.")
 Pandoc, the document-conversion tool.")
     (license license:bsd-3)))
 
+(define-public emacs-hlint-refactor-mode
+  (let ((commit "c4307f86aad6d02e32e9b30cb6edc115584c791c")
+        (revision "1"))
+    (package
+      (name "emacs-hlint-refactor-mode")
+      (version (git-version "0.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mpickering/hlint-refactor-mode")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1c71w9s34n0i7mm4njchxn6s3ri1y6mh3akgbg4nq41d42h8iap3"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("apply-refact" ,apply-refact)
+         ("hlint" ,hlint)))
+      (home-page "https://github.com/mpickering/hlint-refactor-mode")
+      (synopsis "Emacs bindings for @code{hlint}'s @code{--refactor} option")
+      (description "This package applies refactoring suggestions from
+@code{hlint}.")
+      (license license:expat))))
+
 (define-public emacs-ccls
   (let ((commit "aab3e31fd716daf59f9794e62d473357263e8cc0")
         (revision "4"))
-- 
2.24.0