diff mbox series

[bug#45638] gnu: Add nomacs photo lounge.

Message ID CAAaf0CD_ZU1_oHfBGS2iOUi605ji9Udguc3HGaEbL4sGwRqj=g@mail.gmail.com
State Accepted
Headers show
Series [bug#45638] gnu: Add nomacs photo lounge. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Rovanion Luckey Jan. 4, 2021, 11:47 a.m. UTC
Den mån 4 jan. 2021 kl 10:43 skrev Leo Prikler <
leo.prikler@student.tugraz.at>:

> Ehm, that's kinda false advertisement then 😉
>
 Advertisement modified in the attached patch.

Please use a new line after (inputs and don't try to line up the
> columns.
>
Ahw, but I like my aligned columns. Oh well, modified.


> You may want to use ,(version-major+minor version) for the plugins
> commit, if it's known that the two will always be bumped together.  But
> using "3.16" as you did is also fine.
>
The plugins get tagged very irregurarily.

fill-column is 78, also the description is still too long.  Try to
> compact it a bit.
>
Compacted.

Comments

Leo Prikler Jan. 4, 2021, 12:33 p.m. UTC | #1
Hi Rovanion,
Am Montag, den 04.01.2021, 12:47 +0100 schrieb Rovanion Luckey:
> Den mån 4 jan. 2021 kl 10:43 skrev Leo Prikler <
> leo.prikler@student.tugraz.at>:
> > Ehm, that's kinda false advertisement then 😉
> 
>  Advertisement modified in the attached patch.
Thanks.  I've done a little rewording on top.

> > Please use a new line after (inputs and don't try to line up the
> > columns.
> 
> Ahw, but I like my aligned columns. Oh well, modified.
Sure, but aligning leads to much noise when adding inputs.
 
> > You may want to use ,(version-major+minor version) for the plugins
> > commit, if it's known that the two will always be bumped together. 
> > But
> > using "3.16" as you did is also fine.
> 
> The plugins get tagged very irregurarily.
Nvm then.

> > fill-column is 78, also the description is still too long.  Try to
> > compact it a bit.
> 
> Compacted.
Thanks.
I'm about to push that commit with some slight cosmetic changes, but
I've come to see, that #:tests? are #f.  Is there a reason for this?

Regards,
Leo
Rovanion Luckey Jan. 4, 2021, 12:55 p.m. UTC | #2
>
> I'm about to push that commit with some slight cosmetic changes, but
> I've come to see, that #:tests? are #f.  Is there a reason for this?
>

Mistake left from when I redid the build a large number of times and didn't
want to sit through half an hour of tests each time. It should be set to
true before pushing (or the line removed).
Leo Prikler Jan. 4, 2021, 2:10 p.m. UTC | #3
Hi Rovanion,
Am Montag, den 04.01.2021, 13:55 +0100 schrieb Rovanion Luckey:
> > I'm about to push that commit with some slight cosmetic changes,
> > but
> > I've come to see, that #:tests? are #f.  Is there a reason for
> > this?
> 
> Mistake left from when I redid the build a large number of times and
> didn't want to sit through half an hour of tests each time. It should
> be set to true before pushing (or the line removed). 
It turns out, that there is no test target, so apparently you did the
right thing.
I've applied my cosmetic changes, fixed up the commit message and
pushed it as 08f35b9b6ca635f439bc2b01965aeb73e7ec282d.  Thanks!
diff mbox series

Patch

From 5d0f65c6d1686510646ea63a0f832660055e891c Mon Sep 17 00:00:00 2001
From: Rovanion Luckey <rovanion.luckey@gmail.com>
Date: Sun, 3 Jan 2021 19:55:36 +0100
Subject: [PATCH] gnu: Add nomacs photo lounge.

---
 gnu/packages/image-viewers.scm | 56 ++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 0a6be77d24..4674d4ba12 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
 ;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -58,6 +59,7 @@ 
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages image-processing)
   #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
@@ -682,3 +684,57 @@  brightness/contrast/gamma correction, pan with keyboard and mouse, flip,
 rotate left/right, jump/forward/backward images, filename filter and use it
 to set X desktop background.")
     (license license:gpl2)))
+
+(define-public nomacs
+  (package
+    (name "nomacs")
+    (version "3.16.224")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nomacs/nomacs")
+                    (commit version)))
+              (sha256 (base32 "05d4hqg0gl3g9s2xf1hr7mc7g4cqarcap4nzxxa51fsphw2b8x16"))))
+    (build-system cmake-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (arguments
+     `(#:configure-flags (list "-DENABLE_TRANSLATIONS=true"
+                               "-DUSE_SYSTEM_QUAZIP=true"
+                               "-DENABLE_OPENCV=true"
+                               "-DCMAKE_BUILD_TYPE=Release")
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'copy-plugins
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (copy-recursively (assoc-ref inputs "plugins")
+                                        "ImageLounge/plugins")))
+                  (add-after 'copy-plugins 'cd-to-source-dir
+                    (lambda _ (chdir "ImageLounge") #t)))
+       #:tests? #f))
+    (inputs
+     `(("plugins" ,(origin (method git-fetch)
+                           (uri (git-reference
+                                 (url "https://github.com/nomacs/nomacs-plugins")
+                                 (commit "3.16")))
+                           (sha256 (base32 "1cpdwhfvaxm970nwdc1hc13848a85pqqi176m9xpa3krla9qskml"))))
+       ("exiv2" ,exiv2)
+       ("libraw" ,libraw)
+       ("libtiff" ,libtiff)
+       ("opencv" ,opencv)
+       ("python" ,python-wrapper)
+       ("quazip" ,quazip)
+       ("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)
+       ("qtlinguist" ,qttools)))
+    (synopsis "Image viewer for all common formats including RAW.")
+    (description "Nomacs is a simple to use image lounge featuring
+semi-transparent widgets that display additional information such as
+thumbnails, metadata or histogram. It is able to browse images in zip or MS
+Office files which can be extracted to a directory. Metadata stored with the
+image can be displayed and you can add notes to images.
+
+Nomacs includes image manipulation methods for adjusting brightness, contrast,
+saturation, hue, gamma, exposure. It has a pseudo color function which allows
+creating false color images. A unique feature of Nomacs is the synchronization
+of multiple instances.")
+    (home-page "https://nomacs.org/")
+    (license license:gpl3+)))
-- 
2.29.2