diff mbox series

[bug#48717] Add lingot

Message ID CAAaf0CDHT4CJuDRcnkXYrVkiY2h-26=V=CF+sGYyr1zMKK4E8Q@mail.gmail.com
State Accepted
Headers show
Series [bug#48717] Add lingot | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Rovanion Luckey May 28, 2021, 3:21 p.m. UTC
Added a tuner program to the package collection.

Comments

Tobias Geerinckx-Rice May 28, 2021, 5:12 p.m. UTC | #1
Rovanion Luckey 写道:
> Added a tuner program to the package collection.

Thank you!

I should add a copyright line for you at the top of the file, once 
you confirm which name & e-mail address to use.

I made the following changes (pay close attention, they might be 
on the test):
- moved glib:bin to native-inputs, which means it can be run at 
  build time even when cross-building (and ‘guix gc --references’ 
  indicates it won't be run at run time anyway),
- the licence is ‘GPL2 or later’,
- removed the leading ‘An’ from the synopsis (in a list, it's just 
  noise),
- wrapped all text to 80 characters and added a double space after 
  full stops.

Be sure to run ‘guix lint’ on new packages, it will warn you about 
some of these and other cool mistakes.

These minor nitpicks will not be on the test but I applied them 
anyway:
- reindented the package (specifically the source form was off?),
- ordered the inputs alphabetically, and put the package somewhere 
  similar,
- removed the libasound comment because that's 99% of why packages 
  use alsa-lib.  Probably 100.  Could the same be said for 
  glib:bin, which I kept?  Perhaps!  I am whimsy.

Kind regards,

T G-R
Rovanion Luckey May 28, 2021, 7:18 p.m. UTC | #2
You can use the following for the copyright line:

Rovanion Luckey <rovanion.luckey@gmail.com>

I gleaned the license info from GitHub, but I guess it was wrong. Should
really have run guix lint on the package though. Thank you for your
patience.
Rovanion Luckey July 30, 2021, 7:03 p.m. UTC | #3
This patch has been included and this issue closed right?

Den fre 28 maj 2021 kl 21:18 skrev Rovanion Luckey <
rovanion.luckey@gmail.com>:

> You can use the following for the copyright line:
>
> Rovanion Luckey <rovanion.luckey@gmail.com>
>
> I gleaned the license info from GitHub, but I guess it was wrong. Should
> really have run guix lint on the package though. Thank you for your
> patience.
>
Efraim Flashner Aug. 2, 2021, 3:40 p.m. UTC | #4
On Fri, Jul 30, 2021 at 09:03:11PM +0200, Rovanion Luckey wrote:
> This patch has been included and this issue closed right?

Looks like it was committed on May 30th. Closing the bug.
diff mbox series

Patch

From 248c6525564dabe71e130e4f6a48005201d2efdc Mon Sep 17 00:00:00 2001
From: Rovanion Luckey <rovanion.luckey@gmail.com>
Date: Fri, 28 May 2021 17:19:56 +0200
Subject: [PATCH] gnu: lingot: Add package lingot.

* gnu/packages/music.scm (lingot): Add package
---
 gnu/packages/music.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7840e8399a..423c9bd3c7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6639,3 +6639,40 @@  It is provided as an LV2 plugin and as a standalone Jack application.")
   framework.")
       (home-page "http://shiru.untergrund.net/software.shtml")
       (license license:wtfpl2))))
+
+(define-public lingot
+    (package
+      (name "lingot")
+      (version "1.1.1")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ibancg/lingot")
+                      (commit (string-append "v" version))))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "04lcjzfhddbyskxr2068z609y6x0s2gjx1wl78w0dkxdi459zrn9"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("intltool" ,intltool)
+       ("cunit" ,cunit)
+       ("pkg-config" ,pkg-config)
+       ("libtool" ,libtool)))
+    (inputs
+     `(
+       ("alsa-lib" ,alsa-lib) ; for libasound2
+       ("fftw" ,fftw)
+       ("gtk+" ,gtk+)
+       ("glib" ,glib "bin") ; for GLIB_COMPILE_RESOURCES
+       ("jack" ,jack-2)
+       ("json-c" ,json-c)
+       ("pulseaudio" ,pulseaudio)))
+    (home-page "http://lingot.nongnu.org/")
+    (synopsis "An accurate, configurable musical instrument tuner")
+    (description "LINGOT is a musical instrument tuner. It’s accurate, easy to use, and highly configurable. Originally conceived to tune electric guitars, it can now be used to tune other instruments.
+
+It looks like an analogue tuner, with a gauge indicating the relative shift to a certain note, determined automatically as the closest note to the estimated frequency.")
+    (license license:gpl2)))
-- 
2.30.0