diff mbox series

[bug#45638] gnu: Add nomacs photo lounge.

Message ID CAAaf0CBU5O2ZyU-ReZjV5w49ETXhoHwD5ijVO5u5CpTo5X5t+A@mail.gmail.com
State Accepted
Headers show
Series [bug#45638] gnu: Add nomacs photo lounge. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Rovanion Luckey Jan. 3, 2021, 9:38 p.m. UTC
Hi,
I have added a package for the Nomacs Image viewer. It is built with
plugins but not with HEIF or PSD support. I tried creating a package for
the libqpsd package but was unable to get the qt plugin to appear in the
right location. It seems to build fine with `./pre-inst-env guix build
--rounds=2 nomacs` so hopefully its good enough for inclusion despite these
missing features.

Comments

Leo Prikler Jan. 4, 2021, 9:43 a.m. UTC | #1
Hi Rovanion,

Am Sonntag, den 03.01.2021, 22:38 +0100 schrieb Rovanion Luckey:
> It is built with plugins but not with HEIF or PSD support. I tried 
> +    (synopsis "Image viewer for all common formats including RAW and
> PSD.")
Ehm, that's kinda false advertisement then 😉

> +    (inputs `(("plugins"    ,(origin (method git-fetch)
> +                                     (uri (git-reference
> +                                           (url "
> https://github.com/nomacs/nomacs-plugins")
> +                                           (commit "3.16")))
> +                                     (sha256 (base32
> "1cpdwhfvaxm970nwdc1hc13848a85pqqi176m9xpa3krla9qskml"))))
> +              ("exiv2"      ,exiv2)
> +              ("libraw"     ,libraw)
> +              ("libtiff"    ,libtiff)
> +              ("opencv"     ,opencv)
> +              ("python"     ,python-wrapper)
> +              ("quazip"     ,quazip)
> +              ("qtbase"     ,qtbase)
> +              ("qtsvg"      ,qtsvg)
> +              ("qtlinguist" ,qttools)))
Please use a new line after (inputs and don't try to line up the
columns.
You may want to use ,(version-major+minor version) for the plugins
commit, if it's known that the two will always be bumped together.  But
using "3.16" as you did is also fine.

> +    (description "Nomacs is a free, open source image viewer, which
> supports multiple platforms. You can use it for viewing all common
> image formats including RAW and psd images.
> +
> +Nomacs features semi-transparent widgets that display additional
> information such as thumbnails, metadata or histogram. It is able to
> browse images in zip or MS Office files which can be extracted to a
> directory. Metadata stored with the image can be displayed and you
> can add notes to images. A thumbnail preview of the current folder is
> included as well as a file explorer panel which allows switching
> between folders. Within a directory you can apply a file filter, so
> that only images are displayed whose filenames have a certain string
> or match a regular expression. Activating the cache allows for
> instantly switching between images.
> +
> +Nomacs includes image manipulation methods for adjusting brightness,
> contrast, saturation, hue, gamma, exposure. It has a pseudo color
> function which allows creating false color images. A unique feature
> of Nomacs is the synchronization of multiple instances. With this
> feature you can easily compare images by zooming and/or panning at
> the exactly same position or even by overlaying them with different
> opacity.
> +Nomacs is licensed under the GNU General Public License v3 and
> available for Windows, Linux, FreeBSD, Mac, and OS/2.")
fill-column is 78, also the description is still too long.  Try to
compact it a bit.

Otherwise LGTM.

Regards,
Leo
diff mbox series

Patch

From 02f11ae71bca763df181fa1199f835c627bb031a Mon Sep 17 00:00:00 2001
From: Rovanion Luckey <rovanion.luckey@gmail.com>
Date: Sun, 3 Jan 2021 19:55:36 +0100
Subject: [PATCH] gnu: Add nomacs photo lounge.

---
 gnu/packages/image-viewers.scm | 51 ++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 0a6be77d24..9f307d989a 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
 ;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -58,6 +59,7 @@ 
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages image-processing)
   #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
@@ -682,3 +684,52 @@  brightness/contrast/gamma correction, pan with keyboard and mouse, flip,
 rotate left/right, jump/forward/backward images, filename filter and use it
 to set X desktop background.")
     (license license:gpl2)))
+
+(define-public nomacs
+  (package
+    (name "nomacs")
+    (version "3.16.224")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nomacs/nomacs")
+                    (commit version)))
+              (sha256 (base32 "05d4hqg0gl3g9s2xf1hr7mc7g4cqarcap4nzxxa51fsphw2b8x16"))))
+    (build-system cmake-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (arguments
+     `(#:configure-flags (list "-DENABLE_TRANSLATIONS=true"
+                               "-DUSE_SYSTEM_QUAZIP=true"
+                               "-DENABLE_OPENCV=true"
+                               "-DCMAKE_BUILD_TYPE=Release")
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'copy-plugins
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (copy-recursively (assoc-ref inputs "plugins")
+                                        "ImageLounge/plugins")))
+                  (add-after 'copy-plugins 'cd-to-source-dir
+                    (lambda _ (chdir "ImageLounge") #t)))
+       #:tests? #f))
+    (inputs `(("plugins"    ,(origin (method git-fetch)
+                                     (uri (git-reference
+                                           (url "https://github.com/nomacs/nomacs-plugins")
+                                           (commit "3.16")))
+                                     (sha256 (base32 "1cpdwhfvaxm970nwdc1hc13848a85pqqi176m9xpa3krla9qskml"))))
+              ("exiv2"      ,exiv2)
+              ("libraw"     ,libraw)
+              ("libtiff"    ,libtiff)
+              ("opencv"     ,opencv)
+              ("python"     ,python-wrapper)
+              ("quazip"     ,quazip)
+              ("qtbase"     ,qtbase)
+              ("qtsvg"      ,qtsvg)
+              ("qtlinguist" ,qttools)))
+    (synopsis "Image viewer for all common formats including RAW and PSD.")
+    (description "Nomacs is a free, open source image viewer, which supports multiple platforms. You can use it for viewing all common image formats including RAW and psd images.
+
+Nomacs features semi-transparent widgets that display additional information such as thumbnails, metadata or histogram. It is able to browse images in zip or MS Office files which can be extracted to a directory. Metadata stored with the image can be displayed and you can add notes to images. A thumbnail preview of the current folder is included as well as a file explorer panel which allows switching between folders. Within a directory you can apply a file filter, so that only images are displayed whose filenames have a certain string or match a regular expression. Activating the cache allows for instantly switching between images.
+
+Nomacs includes image manipulation methods for adjusting brightness, contrast, saturation, hue, gamma, exposure. It has a pseudo color function which allows creating false color images. A unique feature of Nomacs is the synchronization of multiple instances. With this feature you can easily compare images by zooming and/or panning at the exactly same position or even by overlaying them with different opacity.
+Nomacs is licensed under the GNU General Public License v3 and available for Windows, Linux, FreeBSD, Mac, and OS/2.")
+    (home-page "https://nomacs.org/")
+    (license license:gpl3+)))
-- 
2.29.2