diff mbox series

[bug#58971] gnu: Add avr-gdb.

Message ID CAAGQtHyvBin9fJmoBoej7KbFhAQ-MQgA4sFZk=at9WQjNFCU0w@mail.gmail.com
State New
Headers show
Series [bug#58971] gnu: Add avr-gdb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Kristian Lein-Mathisen Nov. 2, 2022, 7:49 p.m. UTC
I'd like to have avr-gdb available in GNU Guix.
I've used the Arch Linux PKGFILE as basis:

https://github.com/archlinux/svntogit-community/blob/fa92f7b2008ec/trunk/PKGBUILD

I'm hoping this'll be considered for inclusion upstream.

Thanks,
K.

Comments

Christopher Baines Nov. 3, 2022, 5:31 p.m. UTC | #1
Kristian Lein-Mathisen <kristianlein@gmail.com> writes:

> I'd like to have avr-gdb available in GNU Guix.
> I've used the Arch Linux PKGFILE as basis:
>
> https://github.com/archlinux/svntogit-community/blob/fa92f7b2008ec/trunk/PKGBUILD

Hi Kristian,

This seems OK to me, although I don't know what this package is for?

Given this is inheriting from gdb, it'll have the same synopiss and
description:

  synopsis: The GNU debugger
  description: GDB is the GNU debugger.  With it, you can monitor what a program
  + is doing while it runs or what it was doing just before a crash.  It allows
  + you to specify the runtime conditions, to define breakpoints, and to change
  + how the program is running to try to fix bugs.  It can be used to debug
  + programs written in C, C++, Ada, Objective-C, Pascal and more.

So, I think if there is something different about this avr-gdb, it would
be good to specify a appropriate synopsis and description. Does that
make sense?

Thanks,

Chris
diff mbox series

Patch

From daa7559c6c1fb23ab11bdbeb2d81f751a5cc2400 Mon Sep 17 00:00:00 2001
From: Kristian Lein-Mathisen <kristianlein@gmail.com>
Date: Wed, 2 Nov 2022 20:36:51 +0100
Subject: [PATCH] gnu: Add avr-gdb.

* gnu/packages/gdb.scm (avr-gdb): New variable.
---
 gnu/packages/gdb.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)

diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 7d8416c7c5..e09f7cf41a 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -171,3 +171,15 @@  (define-public gdb-minimal
     (name "gdb-minimal")
     (inputs (fold alist-delete (package-inputs gdb)
                   '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
+
+(define-public avr-gdb
+  (package/inherit gdb-12
+    (name "avr-gdb")
+    (arguments
+     `(#:configure-flags
+       (list "--target=avr"
+             "--disable-nls"
+             "--enable-languages=c,c++"
+             "--with-system-readline"
+             "--enable-source-highlight")
+       ,@(package-arguments gdb-12)))))

base-commit: 807bfe55dc382b88ab0fdade6886dfa2b15487ee
-- 
2.38.0