diff mbox series

[bug#41718] Update StumpWM Contrib Package Names and Add New Ones

Message ID CA+TvSRjAg3EnyCTB6MPOs1dTznnGLyST-85We3gx=2XDP0Xk0Q@mail.gmail.com
State Accepted
Headers show
Series [bug#41718] Update StumpWM Contrib Package Names and Add New Ones | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Katherine Cox-Buday June 4, 2020, 10:44 p.m. UTC

Comments

Oleg Pykhalov June 9, 2020, 7:11 p.m. UTC | #1
Hi.

Thank you!  I successfully tested my StumpWM config on a virtual machine
with current changes and pushed them to master.

Oleg.
ashish.is--- via Guix-patches" via June 9, 2020, 10 p.m. UTC | #2
Katherine, Oleg,

Thanks for the patches and testing!  I pushed a bug-fix in commit 
9bb102dc1c47275d2906a9f4e0b813e1940176d3:

+(define-public stumpish
+  (package
+    (inherit stumpwm-contrib)
+    (name "stumpish")
+    (inputs
+     `(("bash" ,bash)
+       ("rlwrap" ,rlwrap)))
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build utils))
+       #:tests? #f

The ‘tests?’ keyword isn't understood by the trivial build system, 
and broke ‘guix pull’.

Oleg Pykhalov 写道:
> Thank you!  I successfully tested my StumpWM config on a virtual 
> machine
> with current changes and pushed them to master.

It's interesting that this didn't throw an error.  I guess the 
only way to test such things is to ‘guix pull’ yourself, which can 
be tedious and slow.

Kind regards,

T G-R
Katherine Cox-Buday June 9, 2020, 10:46 p.m. UTC | #3
Tobias Geerinckx-Rice <me@tobias.gr> writes:

> The ‘tests?’ keyword isn't understood by the trivial build system, and
> broke ‘guix pull’.

Ugh. That was leftover from my own testing anyway, and was meant to be
removed. I'm sorry about that. Ironically I broke myself and I was
wondering why `guix pull` wasn't working. Serves me right!

> It's interesting that this didn't throw an error.  I guess the only
> way to test such things is to ‘guix pull’ yourself, which can be
> tedious and slow.

Yes, that's very strange... is that something that's correctable?
diff mbox series

Patch

From 44a42f6ad1fd83b123152144190238287db6edee Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Thu, 4 Jun 2020 17:30:01 -0500
Subject: [PATCH 1/6] gnu: Add clx-xembed.

* gnu/packages/lisp-xyz.scm (sbcl-clx-xembed, cl-clx-xembed, ecl-clx-xembed):
  New variable.
---
 gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b78eec7f4d..2faeb1e657 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11555,3 +11555,35 @@  accompaniment to the standard ANSI facilities.")
 
 (define-public cl-osicat
   (sbcl-package->cl-source-package sbcl-osicat))
+
+(define-public sbcl-clx-xembed
+  (let ((commit "a5c4b844d31ee68ffa58c933cc1cdddde6990743")
+        (revision "1"))
+    (package
+      (name "sbcl-clx-xembed")
+      (version (git-version "0.1" revision commit))
+      (home-page "https://github.com/laynor/clx-xembed")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/laynor/clx-xembed.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1abx4v36ycmfjdwpjk4hh8058ya8whwia7ds9vd96q2qsrs57f12"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       `(#:asd-system-name "xembed"))
+      (inputs
+       `(("sbcl-clx" ,sbcl-clx)))
+      (synopsis "CL(x) xembed protocol implementation ")
+      (description "CL(x) xembed protocol implementation")
+      ;; MIT License
+      (license license:expat))))
+
+(define-public cl-clx-xembed
+  (sbcl-package->cl-source-package sbcl-clx-xembed))
+
+(define-public ecl-clx-xembed
+  (sbcl-package->ecl-package sbcl-clx-xembed))
-- 
2.26.2