diff mbox series

[bug#41689] Add cl-rdkafka

Message ID CA+TvSRibuVJ2c3wQftqoAvwQO54huaN8unM=p3Z5FgYyrLFV-A@mail.gmail.com
State Accepted
Headers show
Series [bug#41689] Add cl-rdkafka | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Katherine Cox-Buday June 6, 2020, 4:24 p.m. UTC
That is a mistake; there's no reason it can't be listed as a regular input.

During my tests to confirm this, I realized that sbcl-cl-rdkafka
wasn't actually producing any useful output. This led me down a
rabbit-hole (albeit a productive one). Below is a new patch set.

11:23 kate says: guix refresh -l sbcl-lparallel
Building the following 4 packages would ensure 8 dependent packages
are rebuilt: ecl-cl-rdkafka@1.0.2 cl-rdkafka@1.0.2
cl-random-forest@0.1-0.85fbdd4 next@1.5.0

All dependent packages continue to build.

On Fri, Jun 5, 2020 at 9:01 AM Guillaume Le Vaillant <glv@posteo.net> wrote:
>
>
> Hi,
>
> Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:
>
> > (propagated-inputs
> >  `(("librdkafka" ,librdkafka)))
>
> Why is the librdkafka library a propagated input instead of a regular
> input?

Comments

Guillaume Le Vaillant June 7, 2020, 9:17 a.m. UTC | #1
Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:

> That is a mistake; there's no reason it can't be listed as a regular input.
>
> During my tests to confirm this, I realized that sbcl-cl-rdkafka
> wasn't actually producing any useful output. This led me down a
> rabbit-hole (albeit a productive one). Below is a new patch set.
>
> 11:23 kate says: guix refresh -l sbcl-lparallel
> Building the following 4 packages would ensure 8 dependent packages
> are rebuilt: ecl-cl-rdkafka@1.0.2 cl-rdkafka@1.0.2
> cl-random-forest@0.1-0.85fbdd4 next@1.5.0
>
> All dependent packages continue to build.
>
> On Fri, Jun 5, 2020 at 9:01 AM Guillaume Le Vaillant <glv@posteo.net> wrote:
>>
>>
>> Hi,
>>
>> Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:
>>
>> > (propagated-inputs
>> >  `(("librdkafka" ,librdkafka)))
>>
>> Why is the librdkafka library a propagated input instead of a regular
>> input?

Thanks. Patches pushed as 388a89750ec60a320dd7b6a0b0f174cbed4f50c6 and
64174aff927f4f9da18ea452247c838e6bab3306. Except I didn't push the
definition for ecl-cl-rdkafka because it didn't build (because of the
phase moving a file before the cleanup phase IIRC).
Ludovic Courtès June 23, 2020, 9:50 p.m. UTC | #2
Hi,

Guillaume Le Vaillant <glv@posteo.net> skribis:

>>> Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:
>>>
>>> > (propagated-inputs
>>> >  `(("librdkafka" ,librdkafka)))
>>>
>>> Why is the librdkafka library a propagated input instead of a regular
>>> input?
>
> Thanks. Patches pushed as 388a89750ec60a320dd7b6a0b0f174cbed4f50c6 and
> 64174aff927f4f9da18ea452247c838e6bab3306. Except I didn't push the
> definition for ecl-cl-rdkafka because it didn't build (because of the
> phase moving a file before the cleanup phase IIRC).

Katherine, Guillaume: should we close this issue or wait for a fix for
ecl-cl-rdkafka?  (I guess the former.)

Thanks,
Ludo’.
Katherine Cox-Buday June 23, 2020, 10:26 p.m. UTC | #3
Closing is fine. I won't have time in the near future to get the ecl
package working. Thanks ludo!

On Tue, Jun 23, 2020, 16:50 Ludovic Courtès <ludo@gnu.org> wrote:

> Hi,
>
> Guillaume Le Vaillant <glv@posteo.net> skribis:
>
> >>> Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:
> >>>
> >>> > (propagated-inputs
> >>> >  `(("librdkafka" ,librdkafka)))
> >>>
> >>> Why is the librdkafka library a propagated input instead of a regular
> >>> input?
> >
> > Thanks. Patches pushed as 388a89750ec60a320dd7b6a0b0f174cbed4f50c6 and
> > 64174aff927f4f9da18ea452247c838e6bab3306. Except I didn't push the
> > definition for ecl-cl-rdkafka because it didn't build (because of the
> > phase moving a file before the cleanup phase IIRC).
>
> Katherine, Guillaume: should we close this issue or wait for a fix for
> ecl-cl-rdkafka?  (I guess the former.)
>
> Thanks,
> Ludo’.
>
Ludovic Courtès June 24, 2020, 1:11 p.m. UTC | #4
Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:

> Closing is fine. I won't have time in the near future to get the ecl
> package working. Thanks ludo!

Cool, done.  Thank you!

Ludo’.
diff mbox series

Patch

From bfa07340a29c6e028584380f317c6c90d4529d00 Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Sat, 6 Jun 2020 11:18:00 -0500
Subject: [PATCH 1/2] gnu: lparallel: Modify system definition to require
 sb-cltl2

* gnu/packages/lisp-xyz.scm (sbcl-lparallel):
  Modify system definition to require sb-cltl2.
---
 gnu/packages/lisp-xyz.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b78eec7f4d..b47d80b108 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3197,6 +3197,17 @@  WebKit browsing engine.")
      `(("alexandria" ,sbcl-alexandria)
        ("bordeaux-threads" ,sbcl-bordeaux-threads)
        ("trivial-garbage" ,sbcl-trivial-garbage)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-dependency
+           ;; lparallel loads a SBCL specific system in its asd file. This is
+           ;; not carried over into the fasl which is generated. In order for
+           ;; it to be carried over, it needs to be listed as a dependency.
+           (lambda _
+             (substitute* "lparallel.asd"
+               ((":depends-on \\(:alexandria" all)
+                (string-append all " #+sbcl :sb-cltl2"))))))))
     (home-page "https://lparallel.org/")
     (synopsis "Parallelism for Common Lisp")
     (description
-- 
2.26.2