diff mbox series

[bug#41670] Adds Multiple Common Lisp Packages

Message ID CA+TvSRgKbtNsjkaa1G_XW5hu8UiJEUH0usHk-DFAx4OmCBq+Vg@mail.gmail.com
State Accepted
Headers show
Series [bug#41670] Adds Multiple Common Lisp Packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Katherine Cox-Buday June 2, 2020, 7:07 p.m. UTC

Comments

Guillaume Le Vaillant June 5, 2020, 1:55 p.m. UTC | #1
Patches pushed (as b2eae0e1427502b171347fb173bab2547560a707 and
following) with a few modifications (splitting the Prometheus patch in
several patches, sorting inputs, etc.). Thanks.
diff mbox series

Patch

From 2084be27f80bf8a8d510d4b2b2696539e8b46d01 Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Mon, 1 Jun 2020 17:41:40 -0500
Subject: [PATCH 1/8] gnu: Add quantile-estimator.cl.

* gnu/packages/lisp-xyz.scm (sbcl-quantile-estimator.cl)
  (ecl-quantile-estimator.cl, cl-quantile-estimator.cl): New variable.
---
 gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b78eec7f4d..bf679e8f6c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11555,3 +11555,38 @@  accompaniment to the standard ANSI facilities.")
 
 (define-public cl-osicat
   (sbcl-package->cl-source-package sbcl-osicat))
+
+(define-public sbcl-quantile-estimator.cl
+  (package
+    (name "sbcl-quantile-estimator.cl")
+    (version "0.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/deadtrickster/quantile-estimator.cl")
+             (commit "84d0ea405d793f5e808c68c4ddaf25417b0ff8e5")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0rlswkf0siaabsvvch3dgxmg45fw5w8pd9b7ri2w7a298aya52z9"))))
+    (build-system asdf-build-system/sbcl)
+    (arguments
+     '(#:asd-system-name "quantile-estimator"))
+    (inputs
+     `(("alexandria" ,sbcl-alexandria)))
+    (home-page "https://github.com/deadtrickster/quantile-estimator.cl")
+    (synopsis
+     "Implementation of effective computation of biased quantiles over data
+streams")
+    (description
+     "Common Lisp implementation of Graham Cormode and S.
+Muthukrishnan's Effective Computation of Biased Quantiles over Data
+Streams in ICDE’05")
+    (license license:expat)))
+
+(define-public cl-quantile-estimator
+  (sbcl-package->cl-source-package sbcl-quantile-estimator.cl))
+
+(define-public ecl-quantile-estimator
+  (sbcl-package->ecl-package sbcl-quantile-estimator.cl))
-- 
2.26.2