diff mbox series

[bug#41677] Update apache-arrow to v0.17.1

Message ID CA+TvSRgHu0FiKJ0YdYO6fHouzXg3GH_H9NZM-X+eCrc5PVEc0Q@mail.gmail.com
State Accepted
Headers show
Series [bug#41677] Update apache-arrow to v0.17.1 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Katherine Cox-Buday June 2, 2020, 10:35 p.m. UTC
17:34 kate says: guix refresh --list-dependent apache-arrow@0.10.0
Building the following 2 packages would ensure 3 dependent packages
are rebuilt: python-feather-format@0.4.0 python2-pyarrow@0.10.0

All dependencies have been updated to continue building.

Comments

Ludovic Courtès June 9, 2020, 8:47 a.m. UTC | #1
Hello Katherine,

Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:

> From 56162b1b94cbc9a85e7ee7358c9140dd80052cd4 Mon Sep 17 00:00:00 2001
> From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
> Date: Tue, 2 Jun 2020 16:33:36 -0500
> Subject: [PATCH 2/2] gnu: apache-arrow: Update to 0.17.1.
>
> * gnu/packages/databases.scm (apache-arrow): Update to 0.17.1.
> * gnu/packages/databases.scm (python-pyarrow): Update to 0.17.1.
> * gnu/packages/serialization.scm (python-feather-format): Update to 0.4.1.

[...]

> From 8765a3958d8940f3897ce32c22c239a0727e3f23 Mon Sep 17 00:00:00 2001
> From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
> Date: Tue, 2 Jun 2020 16:25:37 -0500
> Subject: [PATCH 1/2] gnu: Add apache-thrift.
>
> * gnu/packages/rpc.scm (apache-thrift): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 8765a3958d8940f3897ce32c22c239a0727e3f23 Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Tue, 2 Jun 2020 16:25:37 -0500
Subject: [PATCH 1/2] gnu: Add apache-thrift.

* gnu/packages/rpc.scm (apache-thrift): New variable.
---
 gnu/packages/rpc.scm | 49 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)

diff --git a/gnu/packages/rpc.scm b/gnu/packages/rpc.scm
index 28c61b54f9..de7d08ae4d 100644
--- a/gnu/packages/rpc.scm
+++ b/gnu/packages/rpc.scm
@@ -25,10 +25,16 @@ 
   #:use-module (guix download)
   #:use-module (guix utils)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (gnu packages adns)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bison)
+  #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cpp)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -192,3 +198,46 @@  browsers to backend services.")
     (description "This package provides a Python library for communicating
 with the HTTP/2-based RPC framework gRPC.")
     (license license:asl2.0)))
+
+(define-public apache-thrift
+  (package
+    (name "apache-thrift")
+    (version "0.13.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/apache/thrift.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "17ckl7p7s3ga33yrjisilsimp80ansqxl54wvpkv0j7vx2zvc13y"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f
+       #:configure-flags
+       (list (string-append "--with-boost="
+                            (assoc-ref %build-inputs "boost")))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)
+       ("flex" ,flex)
+       ("bison" ,bison)))
+    (inputs
+     `(("boost" ,boost)
+       ("libressl" ,libressl)))
+    (outputs '("out" "lib" "include"))
+    (home-page "https://thrift.apache.org/")
+    (synopsis
+     "Lightweight, language-independent software stack for point-to-point
+RPC")
+    (description
+     "Thrift provides clean abstractions and implementations for data
+transport, data serialization, and application level processing.  The code
+generation system takes a simple definition language as input and generates
+code across programming languages that uses the abstracted stack to build
+interoperable RPC clients and servers.")
+    (license license:asl2.0)))
-- 
2.26.2